8

I have attempted to run the Minecraft launcher several times but it won't respond at all. It has previously worked just fine on this machine, the only thing different is that my OS (Windows 10) recently updated, and this is the first time I have attempted to run it since then.

I have tried to troubleshoot it in several ways, I have erased the profiles.json file in .minecraft, to no avail. Then, I tried updating Java. When that failed, I tried running the game in compatibility mode. As a last resort, I went nuclear and completely wiped any Minecraft files in my computer.

All other threads I've found tell me to do one of the above, and it'll work, the rest say that its something to do with a faulty driver, but considering Minecraft is the only thing not working (And I do run a load of games and graphics design programs), I'm a bit skeptical that it's that. After all of those attempts I'm getting a bit worried that it's something related to that fateful Windows update, as they all seem to break something when they happen and unfortunately can't be toggled off (If someone can show me the way to permanently disable those too, I'd be grateful)

Some more system information:

  • Windows 10 Pro 64x
  • GEforce GTX 1050 TI
  • Asus B85 Pro Gamer
  • Intel Core I7 4770 8x @3.4ghz
  • 16GB RAM

Edit: More information, as requested. It's not that the launcher crashes upon executing, it simply won't be executed or opened at all, without any new windows being opened, any error messages, crash logs or new processes in the Task Manager. All I get as a feedback is a split second of the mouse loading animation. I have been told to look through the crash logs, but since I did a fresh install while removing all Minecraft related folders and files from my computer, there doesn't exist a .minecraft directory where the crash logs are being generated. I have also attempted to utilize the alternative launcher, as indicated by another user, as provided in Mojang's website. I run in exactly the same problem: Nothing is opened, I get no new processes, and there are no crash logs. I attempted to execute it with administrator privileges turned on, as well as through the command prompt directly, to no avail. I get the same feedback as trying to open the default launcher, a split second of the mouse loading animation.

8
  • Have you tried checking if there is a log file being created by the launcher? If so, it might contain helpful information. minecrafthopper.net/help/guides/getting-minecraft-launcher-log
    – AJPerez
    Aug 9 at 21:30
  • 1
    @AJPerez I did not, but after a fresh reinstall, .minecraft doesn't even exist, and I can't make it exist because the launcher won't open and create those files. I should clarify - the launcher doesn't crash, because it doesn't open at all. It won't get executed no matter what I do. I tried opening it through the shortcut, I tried opening it directly in the install folder, I tried running it as an administrator, I even tried executing the .exe file through command prompt, the launcher simply won't open at all.
    – Allo
    Aug 10 at 0:25
  • That's also useful info that probably should be edited into your question. There is a difference between "it crashes before showing any window" and "the process doesn't even start". Now we know which one it is. Sadly that's where my knowledge of Java Minecraft ends, but I hope somebody else will be able to help you
    – AJPerez
    Aug 10 at 1:18
  • At this point I'm just googling, which you clearly have done yourself. But... have you tried the alternative launcher? help.minecraft.net/hc/en-us/articles/…
    – AJPerez
    Aug 10 at 1:33
  • can you attempt to run it as an administrator, and then check Task Manager for the Minecraft Launcher process? if possible, can you copy your entire .minecraft folder to a new computer, and see if the game launches from there? preferably on the same version of Windows as your current. Aug 11 at 2:08
-2

Reinstall launcher or install newest version of java jre. Or this and this.

3
  • 1
    I believe the OP already did both things before posting their question
    – AJPerez
    Aug 12 at 15:17
  • @AJPerez possible
    – AnarLezzMC
    Aug 12 at 15:19
  • 1
    Hi AnarLezzMC, welcome to Arqade! As mentioned in the question, it appears the asker already tried those two things. Are there any other troubleshooting steps that you would recommend? You can edit your answer to add additional troubleshooting steps.
    – Gigazelle
    Aug 12 at 16:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.