1

There are numerous threads on this same issue, which I know because I've read a lot of them, but nothing's worked so far.

I had a Debian modded Minecraft server that ran fine apart from a horrendous tickrate (running AllTheMods 3 Remix and GregTech: New Horizons), so a friend gave me an old computer with better hardware to upgrade it. I took the hard drive out of the old computer and put it into the new one, which I expected to cause problems but none that would take this long to fix.

I get io.netty.channel.abstractchannel$annotatedconnectexception whenever I try to connect to the server through a public IP now (local works fine). I have:

  • Opened the port 25565 on my router and server computer
  • Checked my firewall on the client computer allows the application
  • Tried changing settings with iptables
  • Tried using wireless connection instead
  • Making sure the IP in server.properties is blank
  • Checked my Java installation

OpenJDK Runtime Environment (build 1.8.0_302-8u302-b08-1~deb9u1-b08)

OpenJDK 64-Bit Server VM (build 25.302-b08, mixed mode)

I'm 99% sure this is a server problem, I can't recall exactly what I did in iptables so it might be related to the firewall, but I'm out of ideas.

EDIT: I think the problem might be that the port got opened incorrectly somehow, gonna try to change router settings in a bit. Trying to telnet to the server ip with port 25565 couldn't connect either. 25565 shows up at listening while using the ss -l command, but netstat -l doesn't seem to show it.

2