0

So I am on minecraft version 1.16.5, and whenever I place some sort of light source the nearby blocks start looking like this: enter image description here

It just looks so ugly, the block partitions become visible and the wall loooks like it's made up of blocks of the same type but of different shades. I'm using a shader pack, but that's not causing the problem as when I turn it off the problem still persists.

Please provide some possible fix, as I am not able to put lanterns in my house anymore.

Edit: here's an interesting thing... enter image description here This is with smooth lighting set to 100% and to maximum with the shader pack disabled.

Now this... enter image description here When I removed the wall directly In front, it disappeared. It seems like the walls are casting some sort of shadow on each other. Should I just update to 1.17 or there is some other problem?

0

It looks like somehow you switched off Smooth Lighting - press Esc to access the menu, Options, Video Settings, Smooth Lighting, and change it to "Maximum".

Off: enter image description here

Maximum: enter image description here

6
  • Thanks for the reply but the problem still persists, smooth lighting was already set to maximum and only the smooth lighting percentage was low, I set it to hundred but the walls still look the same, I saw the difference between smooth lighting set to minimum and maximum, the walls become even more ugly when set to minimum. Is this because I am on a lower version? Sep 1 at 12:49
  • @Minecraftuser No, the screenshots I posted were taken in 1.16.5, OTOH - are you using some shaders, texture packs, mods affecting rendering (Optifine, Sodium), or anything like that?
    – SF.
    Sep 1 at 13:02
  • Yeah I am using a shader pack, but here's the thing, when I disable it, the lines are still visible but a little less, so the problem is there without the shader pack, do you think that the shader pack is responsible for this? Also I have optfine installed. Sep 1 at 14:10
  • @Minecraftuser I think the mod that allows using the shaderpack is responsible for this. Unmodded vanilla doesn't support external shaders.
    – SF.
    Sep 1 at 14:12
  • So is there any workaround through which I can use the shader without messing things up in game, also for better understanding let me tell you what I did. In the beginning I played on version 1.17 without any shaders and the problem was not there, but then I wanted to use them because it makes everything look more appealing, so i downgraded as there aren't many shaders compatible with the 1.17 yet. And then the problem started appearing, I uninstalled and reinstalled minecraft with optfine in order to run the shader, I just want to use them, is there any way I can do that without this problem Sep 1 at 14:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.