1

I have a problem where I cannot get Roblox Player to fully launch when trying to connect to an Experience (A game). After clicking the play button, the white box with the green progress bar and the Roblox logo pops up, but once it goes away, the Roblox process is basically killed (from what I see in the Task Manager). I can't figure out why this is happening. I've tried a lot of solutions suggested by the Roblox Support Team, myself, and other websites, but none of those solutions seem to work. I hope I do not need to wipe my system or re-install Windows I think this problem may require an advanced solution.

System specs:

  • GTX 1650 LP (4GB)
  • i5-4590 3.3GHz
  • 480gb Kingston SSD
  • 500gb WD HDD
  • 16gb RAM 1666MHz
  • (forgot my PSU)

OS: Windows 10 Pro. Version 21H1 (OS Build 19043.1202)

I currently do not have MSI Afterburner, nor the Rivatuner programs installed for my GPU which have interfered with other programs before.

If anyone needs more info like Logs or something, I'll gladly provide the information in a reply.

6
  • Are you using Windows10Universal.exe (the Roblox launcher from the Microsoft Store), or robloxplayerbeta.exe (downloaded from the website)? Sep 4 '21 at 2:19
  • @DisplayNameNotFound As Windows10Universal doesn't create a new window and simply updates the current window, it's definitely RobloxPlayerBeta.
    – Corsaka
    Sep 4 '21 at 18:11
  • @Corsaka Thanks! Sep 4 '21 at 23:07
  • @VM-431 Could you attempt a full reinstall of the Roblox app? I vaguely remember that working for me the previous time this didn't work. You might need to physically delete the Roblox folder in Program Files.
    – Corsaka
    Sep 6 '21 at 11:22
  • @Corsaka I am using the website version, not the one from the Microsoft store.
    – VM-431
    Sep 8 '21 at 6:00
0

Although I can’t say for certain why this is happening, there may be a fix.

Delete robloxLauncher.exe, then try installing Roblox from the Microsoft Store.

Roblox from the Microsoft store also has better loading time.

Note: the problem might not be your device, it might be that something is blocking roblox.com’s ability to open robloxLauncher.exe, (the application) but I’m just theorizing.

Hope this helped.

4
  • This did help a bit. I have installed the Roblox from the Microsoft store, and that works just fine. I guess I'll have to use that instead of the web version. Thanks!
    – VM-431
    Sep 16 '21 at 5:28
  • @VM-431 No problem! Good luck! Sep 16 '21 at 17:36
  • The web version of Roblox works now.. It was all because of the Nvidia GPU driver I was on. I updated it and it works now!
    – VM-431
    Oct 13 '21 at 2:46
  • @VM-431 Ok, glad to know it works! Oct 13 '21 at 2:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.