4

I spent around one to two hours on a survival server trying to fill in a map (this is early game so I don't have an elytra yet).

I had just finished when I had a sudden urge to kill an enderman. I died and all of my stuff despawned before I managed to get it back.

Is there any way to get back the progress from the previous map without filling it in again by walking around? The server is on Java but supports Bedrock, which is what I am playing on.

1
  • This may be different with bedrock-java cross-play Do check Radon8472's answer and see if it works
    – Jmooroof
    Commented Oct 18, 2021 at 0:06

2 Answers 2

2

Unless you made a clone of that map, all your progress is lost.

An easy solution is asking another player to clone you a complete map.

3

If you have admin permissions (or in singleplayer go to "open lan game" with "enabled cheats", you can use the command:

/give @p filled_map{map:#}

So e.g. if you lost the map with the number 20, type

/give @p minecraft:filled_map{map:20} 1

If you don't know the number of the map, go to you world-folder and take a look into the data directory, there will be files named e.g. map_20.dat.

Every file you see there was/is one map that somebody created on you map. So you just need to try all existing numbers until you get the correct map.

For the future I would advise you: Always make a copy of important maps and keep in a safe place.

When one of the maps gets lost, you will see, that the map-copy will always have the same state like the "original" map (because the data of all maps with the same ID is stored in the same file in you savegame)

EDIT:

@Michael asked how the command for bedrock would be. Unfortunally I can`t test it on bedrock, but according the minecraft wiki article about the give command, the syntax for bedrock is minimal different like this:

/give command bedrock

According this example I thing the correct bedrock syntax to get a filled map should be:

/give @p minecraft:filled_map 1 0 {map:20}

7
  • Can you do this in bedrock? It doesn't like the "{" and it seems if I try e.g. "1 n" no matter what n I give it, it always gives me a map of where i'm currently at
    – Michael
    Commented Jan 31, 2022 at 19:48
  • @Michael I found something in minecraft wiki, that should work in bedrock, but I cant test it because I dont have bedrock edition. So it would be nice if you could leave a comment if that command works for you.
    – Radon8472
    Commented Feb 7, 2022 at 10:36
  • Thanks, I've previously tried this with the map key in quotes and got the error Component 'map' was not an object. and I think I tried without quotes and got a different error. I'll try this again as soon as I get back.
    – Michael
    Commented Feb 7, 2022 at 17:17
  • When I try /give @p minecraft:filled_map 1 0 {map:20} I get this error: * Line 1, Column 2 Missing '}' or object member name
    – Michael
    Commented Aug 20, 2022 at 17:06
  • @Michael do you play the latest version of minecraft ? The command Syntax changed from time to time, so maybe you have a different syntax, when you play an older version
    – Radon8472
    Commented Aug 20, 2022 at 20:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .