I am a relative newbie to Minecraft. I setup a little Minecraft server (Nukkit) on a Raspberry Pi a few weeks back for my daughter.

We can not figure out how to get Pistons to do anything.

We tried placing a block of Redstone directly under a piston. Nothing. We tried making a trail of Redstone dust with a lever. We pull the lever, the Redstone dust lights up but the piston does nothing? We tried both normal and sticky pistons.

We tried putting a block of dirt on top of the piston, still nothing.

We typically play from our iPhones, but I tried from Windows 10 MS Store version and have the same problem.

enter image description here

  • 1
    Maybe you can add a screenshot so we can explain what you are doing wrong
    – pinckerman
    Nov 7, 2021 at 9:47
  • 1
    @pinckerman Screenshot added. Nov 8, 2021 at 14:48

3 Answers 3


Answer moved from body of question

SOLUTION: As @SF. noted in the accepted answer below, Nukkit is lacking support for pistons and is missing some items in inventory.

In investigating a replacement that would run on a Raspberry Pi 3B+, I stumbled upon a maintained fork of Nukkit, called PowerNukkit. This appears to solve the redstone-powered issues (at least piston operation) that are present in Nukkit. It also adds additional items for your building pleasure.

I simply backed up my nukkit directory, downloaded the latest JAR for PowerNukkit, placed it in the nukkit folder, renaming it to nukkit.jar, and then restarted my server.

Pistons now work.


Pistons don't work on Nukkit and it's going to be a good while until they do. It's a minimalistic server missing some quite important features. You may try your luck with vanilla server for Bedrock which is currently in alpha, or run a Java Edition server with GeyserMC which is a bridge/converter software that allows Bedrock Edition players to play on JE servers.

  • Oh fun! Would either of those servers run on a Raspberry Pi 3? And if so, can you transfer worlds you have modified on a Nukkit server to one of those other servers? My daughter has done a lot of building and would not be cool with losing all of it. Nov 8, 2021 at 17:48
  • @eat-sleep-code Java Edition should, albeit I'm not sure if Geyser will. A world should be transferrable directly between the same variant (Bedrock - Bedrock, Java-Java) and there's a paid tool to convert the worlds between variants. As for vanilla Bedrock server, not a clue.
    – SF.
    Nov 9, 2021 at 10:01
  • 1
    I found PowerNukkit, a fork of Nukkit which pistons work fine on -- woohoo! Nov 13, 2021 at 14:18
  • 1
    The officially supported Chunker tool developed by the Hive is free to use to convert worlds from different editions.
    – slink
    Nov 14, 2021 at 21:41

How to: Activate a piston.

The first thing you need to know is where the red stone dust or block (also known as “input”) needs to go. An input must face any side except the top piston part (ie the thing that pushes the block).

In addition, if you are using red stone dust, you need to make sure that it is facing directly into (not beside) the piston. This can be confirmed if the dust suddenly stops in a line facing into the piston.

If that doesn’t work…

• Make sure that the piston is not pushing >=12 blocks.

• Make sure that the piston is not trying to move an immovable object (think obsidian, bedrock, chests)

• Try placing a repeater facing into the piston, then power it.

  • 1
    Chests can actually be pushed in Bedrock, but the server software might alter that.
    – slink
    Nov 7, 2021 at 18:14
  • 1
    @DisplayNameNotFound I literally tried putting a redstone block, with a sticky piston on top of it, with the brown/green part facing up. I tried putting nothing on it and putting a block of gray concrete on it -- still nothing. Nov 8, 2021 at 14:02
  • @Pikatchoo32, I added a screenshot if it is any help. Nov 8, 2021 at 14:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .