4

I've already stumbled upon some similar threads, but none on version 1.17. So my issue is, I want to make custom items (sword, armors…) with custom attributes. I tried copy/pasting some commands, but none worked. It keeps telling me that the item name is unknown, here's an example of command :

/give @p diamond_sword{Unbreakable:1,AttributeModifiers:[{Slot:"mainhand", AttributeName:"generic.attack_damage", Amount:100000.0, UUID:[I; -1, -1, -1, -1]},{Slot:"mainhand", AttributeName:"generic.movement_speed", Amount:1, UUID:[I; -1, -1, -1, -1]}]} 1

It's from a tutorial for Minecraft 1.16.5, so I suppose that it does not work the same in 1.17.1.

2

Firstly, that's not /attribute, that's /give, you're using attribute modifiers. The command should work, or at the very least not say the item name is unknown - it sounds like you've got a plugin here that's using the old /give syntax. What happens if you use /minecraft:give @p ... instead?

3
  • 1
    Your answer could be improved with additional supporting information. Please edit to add further details, such as citations or documentation, so that others can confirm that your answer is correct. You can find more information on how to write good answers in the help center.
    – Community Bot
    Nov 22 at 7:38
  • Yes it was because of a plugin using it's own /give, so the /minecraft:give work fine. Thanks for the answer.
    – Althoris
    Nov 22 at 21:29
  • @Althoris Please mark this as the answer using the check mark
    – Hacker
    Nov 27 at 17:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.