1

I have been trying to setup a Minecraft Bedrock server on Windows, however its not working.

The server is setup on a Windows Desktop, and I'm trying to connect from a iPad Mini (The docs say that this is possible). The only time I can connect is when both are on the same network, and it only appears under "Friends", I can never connect from the "Server" screen See Below (I always get a "Cannot connect to server error" if using the public IP). I have tried running the server from my main network and my eero network, the same error is still given.

I have a eero network setup, and I have port forwarded port 1932 on both my main network and the eero.

bedrock_server.exe is allowed though the Windows Firewall for both "Public" and "Private". It gives the follow messages on startup:

NO LOG FILE! - [] setting up server logging...
[2021-12-29 11:06:36:586 INFO] Starting Server
[2021-12-29 11:06:36:587 INFO] Version 1.18.2.03
[2021-12-29 11:06:36:587 INFO] Session ID 17e4524f-ebbf-4aa3-9d94-317020068a5c
[2021-12-29 11:06:36:589 INFO] Level Name: Bedrock level
[2021-12-29 11:06:36:590 INFO] Game mode: 0 Survival
[2021-12-29 11:06:36:591 INFO] Difficulty: 1 EASY
[2021-12-29 11:06:36:701 INFO] opening worlds/Bedrock level/db
[2021-12-29 11:06:37:594 INFO] IPv4 supported, port: 19132
[2021-12-29 11:06:37:596 INFO] IPv6 supported, port: 19133
[2021-12-29 11:06:38:787 INFO] Server started.
[2021-12-29 11:06:38:057 INFO] IPv4 supported, port: 65162
[2021-12-29 11:06:38:058 INFO] IPv6 supported, port: 65163

I used the IPv4 address (IPv6 is not supported on my eero) from whatismyipaddress.com and the server port 19132 to connect to the server from my iPad.

Port Forwarding on my main router: enter image description here

Thanks in advance

EDIT: canyouseeme.org also reports that the post is closed with the error "Connection timed out". I don't know why this is happening, everything looks correct from my end.

EDIT2: I do not have MC installed on the host machine I can load the world from my iPad if its on the same network and the local IP is used.

EDIT3: MC on my iPad now finds it (And shows the "Current Ping" as 14), however it still returns the "Unable to connect to world" error. The port checker still shows the port as closed.

EDIT4: Solved

8
  • 1
    There are a few things that we would need to know to take this further. Can you join via a different device via either the local IP address or the port forward address? Can you join from the host machine using localhost? Can you join from the host machine using the local IP address of the host machine (192.168.1.xxx)?
    – Josh Hales
    Dec 29, 2021 at 18:35
  • I cannot join from the host machine at all, and that's only because I don't have MC on it. Yes! I can join by Local IP on the same network from my other device. Dec 29, 2021 at 18:50
  • Therefore, the issue must be with the port forwarding. What OS is the server running on? That will help me out a lot for the next steps of debugging.
    – Josh Hales
    Dec 29, 2021 at 19:17
  • The server is running on Windows 11 Dec 29, 2021 at 19:23
  • Can you get any other processes such as a Python web server running through a portforward?
    – Josh Hales
    Dec 29, 2021 at 20:06

1 Answer 1

1

Here is how I solved this for others:

  1. Setup Port Forwarding on both the eero network, and the home router
  2. Get someone on a DIFFERENT network to test it, using the IP from google (Google "What is my ip") and the port from the MC server settings.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .