9

I received Fallout 4 for Christmas and installed it through Steam. I fired it up and found I'm getting <10 FPS. I tried a few things (see below) and then, in my sadness, fired up Subnautica, only to find it is getting 4-5 FPS. It was running fine two months ago which was the last time I tried it. So I tried a few other games:

Game FPS Engine
Fallout 4 (Steam) 7-9 Creation
Subnautica (via Epic Games Launcher) 4-5 Unity
AC Odyssey (Steam through UbiSoft Connect) 60 AnvilNext 2.0
Portal 2 (Steam) 60 Source
Elder Scrolls V: Skyrim (Steam) 7 Creation Engine
Stellaris (Steam) 55-60 Clausewitz
Kerbal Space Program (Steam) ~5 Unity Engine
No Man's Sky (Steam) 60 Modified Unity

My first thought was an engine problem, since it is affecting both Fallout and Skyrim and they're both on the Creation Engine but Subnautica and KSP are on Unity, so that doesn't explain it. It FEELS like a library problem, like the install of Fallout overlaid a (possibly older) copy of something on top of the current version? Is there something that is used by both Unity and Creation that could account for this kind of behavior? Or maybe it configured the OS to use... something it shouldn't be using?

So far I have:

  • checked Windows Updates (I'm up to date)
  • updated video drivers (Nvidia GeForce RTX 3080 - 30.0.14.9729)
  • uninstalled and reinstalled all copies of MS Visual C++ (2008, 2010, 2012, 2013, 2015-2022)
  • checked for updated dll's by file modification date of the Fallout 4 install: none
  • checked for all updated files by file modification date of the Fallout 4 install: umpteen, but none seem like likely candidates (I can get the list if someone thinks it might be useful)
  • uninstalled Fallout 4, Subnautica still broken
  • reinstalled Subnautica both with and without Fallout 4, still broken
  • cranked all in-game (FO4) video setting to the very minimum, although given the strength of the box and video card, it should be playable at high everything

I have noticed that, in FO4, if I am indoors and looking at the ground, I can get as high as 25-30 FPS. But if I step outdoors and look at... anything, I'm back to 4-5.

Any thoughts or suggestions?

Benchmark

Nvidia System Information

[Display]
Operating System:   Windows 10 Home, 64-bit
DirectX version:    12.0 
GPU processor:      NVIDIA GeForce RTX 3080
Driver version:     497.29
Driver Type:        DCH
Direct3D feature level: 12_1
CUDA Cores:     8704 
Resizable BAR       No
Core clock:     1710 MHz 
Memory data rate:   19.00 Gbps
Memory interface:   320-bit 
Memory bandwidth:   760.08 GB/s
Total available graphics memory:    18397 MB
Dedicated video memory: 10240 MB GDDR6X
System video memory:    0 MB
Shared system memory:   8157 MB
Video BIOS version: 94.02.26.40.FC
IRQ:            Not used
Bus:            PCI Express x8 Gen4
Device Id:      10DE 2206 38911028
Part Number:        G132 0030

[Components]

nvui.dll        8.17.14.9729    NVIDIA User Experience Driver Component
nvxdplcy.dll        8.17.14.9729    NVIDIA User Experience Driver Component
nvxdbat.dll     8.17.14.9729    NVIDIA User Experience Driver Component
nvxdapix.dll        8.17.14.9729    NVIDIA User Experience Driver Component
NVCPL.DLL       8.17.14.9729    NVIDIA User Experience Driver Component
nvCplUIR.dll        8.1.940.0   NVIDIA Control Panel
nvCplUI.exe     8.1.940.0   NVIDIA Control Panel
nvWSSR.dll      30.0.14.9729    NVIDIA Workstation Server
nvWSS.dll       30.0.14.9729    NVIDIA Workstation Server
nvViTvSR.dll        30.0.14.9729    NVIDIA Video Server
nvViTvS.dll     30.0.14.9729    NVIDIA Video Server
nvLicensingS.dll    6.14.14.9729    NVIDIA Licensing Server
nvDevToolSR.dll     30.0.14.9729    NVIDIA Licensing Server
nvDevToolS.dll      30.0.14.9729    NVIDIA 3D Settings Server
nvDispSR.dll        30.0.14.9729    NVIDIA Display Server
nvDispS.dll     30.0.14.9729    NVIDIA Display Server
PhysX               09.21.0713  NVIDIA PhysX
NVCUDA64.DLL        30.0.14.9729    NVIDIA CUDA 11.5.125 driver
nvGameSR.dll        30.0.14.9729    NVIDIA 3D Settings Server
nvGameS.dll     30.0.14.9729    NVIDIA 3D Settings Server

DiagDx

(not sure what is and isn't relevant)

------------------
System Information
------------------
      Time of this report: 1/3/2022, 18:24:15
             Machine name: PIGPEN
               Machine Id: <snip>
         Operating System: Windows 10 Home 64-bit (10.0, Build 19042) (19041.vb_release.191206-1406)
                 Language: English (Regional Setting: English)
      System Manufacturer: Alienware
             System Model: Alienware Aurora Ryzen Edition
                     BIOS: 2.2.4 (type: UEFI)
                Processor: AMD Ryzen 7 3700X 8-Core Processor  (16 CPUs), ~3.6GHz
                   Memory: 16384MB RAM
      Available OS Memory: 16314MB RAM
                Page File: 10506MB used, 11439MB available
              Windows Dir: C:\Windows
          DirectX Version: DirectX 12
      DX Setup Parameters: Not found
         User DPI Setting: 96 DPI (100 percent)
       System DPI Setting: 96 DPI (100 percent)
          DWM DPI Scaling: Disabled
                 Miracast: Available, no HDCP
Microsoft Graphics Hybrid: Not Supported
 DirectX Database Version: 1.0.8
           DxDiag Version: 10.00.19041.0928 64bit Unicode
8
  • Hi, welcome to Arqade! This all happened since installing FO4? Can you remember or think of anything else that has changed around that time?
    – Joachim
    Jan 7 at 7:17
  • 1
    Based on the FPS, it seems your GPU is not being used properly. Can you go to the Nvidia Control Panel → Manage 3D Settings → Program Settings → select Fallout4.exe, and select 'High Performance NVIDIA processor' under (2), and see if that changes anything.
    – Joachim
    Jan 7 at 7:22
  • 2
    Have you tried restarting your computer? This happens to me sometimes after putting the computer to sleep (GTX 2800 TI, up to date drivers). After restarting, everything is back to normal. Jan 7 at 7:53
  • @BlueRaja-DannyPflughoeft. Multiple times.
    – tdelap
    Jan 7 at 16:07
  • 1
    @Joachim I went to the Nvidia Control Panel and updated the 'OpenGL rendering GPU' and 'CUDA - GPUs' to force use of my Nvidia card. No difference. I also fired up the game and monitored GPU usage on the Control Panel. The GPU is being used (~20%).
    – tdelap
    Jan 7 at 16:43

1 Answer 1

4

Follow-up: I gave up and punted. After trying upgrading to Windows 11, reinstalling DirectX 12, multiple version of drivers and validating OpenGL, none of which helped, I backed everything up and reinstalled Windows from scratch. This seems to have done the trick. Thank you to everyone! I really appreciate your suggestions. Plus now I know a lot more for next time. Yay?

And to anyone having the same issue who came here looking for help, sorry.

"I say we take off and nuke the entire site from orbit. It's the only way to be sure." - Ripley

1
  • 1
    Yeah, it's aggravating when things that should work don't (well, obviously, it 'shouldn't' have worked because it didn't, so something was simply wrong - it's not like hard- or software simply refuses to function). I do wonder what could have caused your problem. Re-installation of GPU drivers would have been my next advice, but I fully understand you're just glad you can play again :)
    – Joachim
    Jan 8 at 22:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .