I am currently playing Icewind Dale Gold, an outstanding D&D based dungeon crawler. It works with almost no problems on my Pentium 4 2.93GHz Prescott, 1.5GB RAM DDR2 and Radeon HD4650 1GB PciE, running Windows XP SP3 and DirectX 9.0c.

However, there is only one minor issue that I was not able to fix no matter what - it is the Mirrored Sprites option, accessible from games setup, under Graphics tab. Basically, it makes characters' sprites animation being mirrored, i.e. when character is facing right and hold his shield in his right hands, then after turning and facing left the shield is immediately swapped to his left hand, being a mirror reflection of his previous stance. In the old days it allowed to save some memory and increase game performance. Nowadays I am not able to turn this option off - it is always active.

I noticed this happens in almost every game based on Infinity engine I tried in the past years (Icewind Dale 2, Baldur's Gate Gold). I also used different hardware specs (Radeon 9550 AGP, Pentium 4 2GHz Northwood, Celeron D 3.2GHz, Athlon 2400XP+, DualCore E5200), with no results.

Do you by any chance know if it is a known bug and is there is any solution for this?

Just note I use localized, Polish versions of these games - could this problem be version-specific?

Thank you in advance.

  • 1
    I could swear I have seen a similar question, can't find now where.. – DrFish Dec 1 '11 at 10:34
  • Hope there was one and it was answered :) – acalypso Dec 1 '11 at 10:39
  • What happens if you force it off in the icewind.ini? Not sure what the setting is called (I don't have an installed version currently), but it should be there somewhere. – Edwin de Koning Dec 1 '11 at 11:12
  • Yes it is there - Sprite Mirror=0. That is what I have, so it seems it is saved correctly when exiting setup, but does not work. I can try to change it to 1 to see what happens though. – acalypso Dec 1 '11 at 11:30
  • I never noticed this on my more modern PCs. Now I'll have to load it and see. – Xantec Dec 1 '11 at 13:02

I've had some serious problems with IceWind Dale 1 and 2 on modern systems. After some heavy experimenting, someone told me to disable 2D DirectX acceleration in dxdiag, and that solved the problems.

Try it out.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.