1

I've got the Samsung Note Pro tablet on the latest android 5.0.2

I've got 2 gamepads which work on the Xbox 360 and when I try to use them on the tablet none of them are recognized.

I've followed all guides I've found around in this and other sites talking about the subject and:

  • I've got a root device
  • I've been able to find the Vendor and ProdID of both by looking into `/sys/kernel/debug/usb/devices'
    • both of the USB wired controllers appear there
      • gamepad 1 = vendor 0738, prodID 4738
      • gamepad 2 = vendor 1bad, prodID f025
  • So I've created the following files with the config of an Xbox 360 controller:
    • /system/usr/keylayout/Vendor_0738_Product_4738.kl
    • /system/usr/keylayout/Vendor_1bad_Product_f025.kl
  • Just in case, I tried with and without the following too:
    • /system/usr/keychars/Vendor_0738_Product_4738.kcm
    • /system/usr/keychars/Vendor_1bad_Product_f025.kcm
  • All of those have the right 644 rw-r--r-- permissions

After all changes, rebooting and reconnecting... still, none of the 2 controllers are recognized by this Android tablet.

I checked the following with each of them plugged in, and they were not appearing as connected:

  • /proc/bus/input/devices

Any idea what the problem could be? Or what else could I try? Most guides talk about the .kl files above and they say it should work, but in this case, it doesn't... any other suggestion?

Ta

2
  • Which app are you trying to use them in? 0738:4738 is "Mad Catz Wired Xbox 360 Controller (SFIV)" and 1BAD:F025 is "Mad Catz Call Of Duty", both have been supported by xpad for years so I'd expect them to work correctly without a keylayout file.
    – nondebug
    Commented Feb 7, 2022 at 20:31
  • @nondebug, the main one I want, where it doesn't appear as recognized is RetroArch, but I've tried several other game tester apps from play store and they don't recognized them either. And checking the values in /proc/bus/input/devices none of them appear as connected there. As for the keylayout files, those 2 vendors/productIds were not appearing for me, so just in case I put them. but still no luck. Do you have any other idea that I could try?
    – mickael
    Commented Feb 8, 2022 at 14:41

0

You must log in to answer this question.

Browse other questions tagged .