I am trying to make a mini-game on Minecraft bedrock. In the mini-game different blocks that you place activate different things, but when I tried using the red wool command it kept telling me there was an unexpected error.

The command is:

execute if -43 4 139 Minecraft:wool 14 run setblock -19 4 169 redstone_block replace

I tried everything I could, Minecraft:wool 14, Minecraft:red_wool, etc.

  • Welcome to Arqade! Please note that we are not a forum, we are a knowledge base of popular questions about video games. We would prefer that you take effort into formatting your posts so that they will serve well for future readers to browse. Mar 21, 2022 at 2:23

1 Answer 1


This is an issue with the fact that you used a command that was created for Minecraft Java Edition, but you are attempting to run it on Minecraft Bedrock Edition.

The correct way to accomplish your task on Minecraft: Bedrock Edition would be to use the /testforblock command to test for the block's existence, then follow that with a chain, conditional command block which runs the desired command:

Impulse command block testforblock -43 4 139 wool 14
Chain command block, set to conditional setblock -19 4 169 redstone_block

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .