0

I'm new to commands, so it's very likely that I'm missing something obvious. I'm trying to teleport myself from the Overworld to specific coordinates in the Nether.

The command works in the command line, but when I try to run it in a command block, the "loading terrain" screen displays for about two minutes before loading what appears to be a void in which I can't move or break/place anything. When I quit and re-load the world, I'm in my original location in the Overworld and the command block output says:

"An unexpected error occurred trying to execute that command."

I'm running Java edition 1.18.1 with Forge, optifine, and WorldEdit 7.2.9. The command I'm trying to run is:

/execute as @p in minecraft:the_nether run tp @p ~ ~ ~ 

I've also tried:

/execute as @s ...
/execute as @e ...
/execute as @p at @s ...
/execute in minecraft:the_nether ...

But, as I said, I really don't know what I'm doing, so I have no idea what the problem could be to begin with.

Somebody please help!

2
  • Are you teleporting to "~ ~ ~"? If so, that may be causing a little issue, try entering specific coordinates.
    – Diehe
    Commented Mar 28, 2022 at 19:35
  • @Diehe I did use specific coordinates. Weirdly, I found the command worked more often if i used my username instead of @p, which is fine because it's a private world. It also works better if Im not using Forge. Commented Mar 30, 2022 at 17:46

1 Answer 1

-1

These ~ are to signify the current location of a person. So if a player is below Y=0, then they teleport below the bedrock in the Nether.

A tip with the /execute command, since you used as @p you can just simply do run tp ~ ~ ~ and it works perfectly fine.

So the command that works in command blocks for me is:

execute @p in minecraft:the_nether run tp ~ ~ ~

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .