I am trying to run multiple servers at the same time using MineOS Crux. I am new to this so hopefully this is not obvious. I am experimenting right now with MineOS Crux running on a VirtualBox, and that all runs and works as expected. I can launch the WebUI, and configure the servers, but then when I run the Minecraft client from the Host PC, and try to connect to the servers running on the Virtual PC by using the Add Server screen in client and specifying both IP and Port (as IP:PORT), I seem to only ever be able to connect to one, and only if that one is running on the default port (25565).

I have tried setting different port numbers for the different servers, and that allows them to both start, but then in the client I can't connect to the second one.

I have tried setting port forwarding on my router to both the host PC and the MineOS Crux virtual PC, but no luck either way (although after thought I realized that shouldn't matter because my host PC and my VM server are both inside my router network).

I want to be able to have 2 or more servers running at the same time so that multiple worlds are available from the server.

Is there something I'm missing, or can this not be done? I could perhaps make multiple virtual PCs, and run separate MineOS Crux servers in them, but is that the only way?

Maybe to clarify:

Perhaps my first question should be: Is it possible to run more than one vanilla Minecraft server from a single instance of MineOS Crux and connect to them simultaneously from separate clients?

  • Are you specifying the port when you connect? e.g. show us exactly what you type in as the IP. Dec 2, 2011 at 4:25
  • How is networking setup for your VMs? Bridged?
    – Zoredache
    Dec 2, 2011 at 4:43
  • @John Not an issues with how I enter the IP, unless it is related to trying to access virtual PC from Host PC. In the client I am typing the full address into the Add Server screen with the IP:Port. Dec 2, 2011 at 12:28
  • @Zoredache I am using bridged. I had to do that to get anything to work. Using bridged allowed my VM to get IP from Router's DHCP. Before switching to bridged, the VM was not showing up on my network. Dec 2, 2011 at 12:29

4 Answers 4


Well, I found the answer but I can't take credit for it. I emailed the creator of MineOS Crux directly, William Dizon, and he got back to me in the same day! Very impressed.

Turns out that the default installation of MineOS Crux sets up the Linux firewall (iptables) to only accept incoming Minecraft connections on the default port, 25565. That means even though my second server was merrily running away, any attempts at connecting were blocked. Mr. Dizon passed on this link from the MineOS Crux wiki that explains how to add additional ports to the iptables:


Once I followed the steps, set up my additional port for the second server, everything worked! I had forgotten about iptables, and that is a little embarrassing, but live and learn... again ;)

Thanks again to Will Dizon!


Most likely, you're inputting an IP that looks something like this:


That leaves off the port number, which is required for a connection. In this case, Minecraft assumes a default port number of 25565, meaning you connect only to the server running on port 25565. To connect to one running on, say, 25566, you would do this:


  • Just to follow up as I said above, I have been entering the full address from the beginning of my efforts, i.e. IP:Port. Dec 2, 2011 at 12:30

This seems strange, but it may be a vanilla server limitation, assuming you're doing things right.

However, if you do port forwarding to separate VM's, it should work.


You can't run two programs on one port. For example, if I run a Minecraft server on the port Skype uses, I won't be able to run both at the same time. If I use the standard port on both Minecraft servers, only one Minecraft server can run.

  • 1
    Two applications can't simultaneously use the same port due to the fact that only application can have any given port file descriptor open at a time.
    – CyberSkull
    Aug 22, 2012 at 0:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .