I was creating a Minecraft mini-game on my Nintendo switch Minecraft bedrock because that's the version I play the most. But every time my friends try to join my world it says they are unable to connect to world. My friends are Xbox and PlayStation players so I thought it was probably a cross-play issue:

But when I join their world it allows me very easily so I thought it must be a problem with the Nintendo Switch:

But I thought that to be un-likely so I tried joining my brother's world as a test since he is on PlayStation 4, but just like my friends, it said unable to connect to world. I tried this multiple times and it never worked, even when he tried to join my worlds. But we can both join our friends' worlds.

So, as one final test, I told my friends to try and join both my and my brother's worlds and again it was the same thing for both of us, unable to connect to world. So now I am thinking that it has something to do with my internet or Network settings but I have no idea how I could possibly fix that.


1 Answer 1


I believe you are running into what sounds like a network issue on your end, specifically a strict NAT type. From the link, it states the following about strict NAT types:

You're only able to play multiplayer games with people who have an OPEN NAT type. You can't be chosen as the host of a match.

Here is a more relevant article about NAT and Nintendo Switch. It states:

For Nintendo consoles, NAT Types range from Type A (best for peer-to-peer communication) to F (unable to complete peer-to-peer communication). If your NAT type is A or B, your console is connected properly and shouldn't run into issues. If you are having problems, this may just be a glitch with your connection and may be resolved with a simple reboot. The remaining NAT types, C through F, generally indicate that there is some sort of restriction or blockage that is preventing your console from communicating properly. This means that your router's settings will have to be altered to allow proper communication, or might be altogether incompatible with your game console.

You can check your NAT type by going to the System Settings -> Internet -> Test Connection. One of the items listed after testing your connection is the NAT type. If you are of type C, D, E, or F, you likely will need to do some troubleshooting of your network, likely something with your router. The same article says to try:

  • Open required ports via Port Forwarding within your router.
  • Enable the DMZ (demilitarized zone) setting for your game console within your router. This opens all ports of communication for a specified device that's connected to your router.
  • Enable UPnP (Universal Plug and Play) on your router.

Chances are, you will likely need to port forward. You will need to allow UDP connections on ports 19132 and 19133:

BDS uses UDP, unlike Java Edition which uses TCP. The default port for IPv4 is 19132, the default port for IPv6 is 19133; these can be changed in server.properties.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .