I am using Fightcade 2 to try playing retro arcade games

One of those games is a PC-Engine / TurboGrafx-16 game

I am using a Nintendo Switch gamepad with Fightcade

For some NeoGeo games, the button mapping window is very specific, like P1 LightPunch, P1 LightKick or something like that for Street Fighter 3rd Strike for example

But for this game in particular, it just says: P1 Button 1, P1 Button 2, P1 Button 3 and so on

The mapping on the start and select buttons work just fine as I can pause in game, but my mappings for the six action buttons, it seems like it doesn't as only the mappings to Button 1 and Button 2 are responding, but my character seem to do the same thing whether I press the one or the other: a heavy kick

I already tried to remap the controls with different buttons but the same problem occurs

I have not tried mapping on the keyboard yet

pc-engine mapping window

This screenshot is done from my work computer just to demonstrate the default mappings it shows

Can anyone give me an input mapping that would work?


You must log in to answer this question.

Browse other questions tagged .