I started the quest where Vilkas asks me to accompany him to the flame to cure himself.

But it won't let activate the flame and says the quest is complete even though I haven't done anything, and Vilkas is nowhere to be seen.

Is it because I fast traveled to the location?


1 Answer 1


This a known bug caused by accepting Vilkas's Purity quest before Farkas. To resolve it accept and finish Farkas's Purity quest first and be sure that the quest giver is following you the whole way through.

To avoid bugs on this quest

  • First speak to Vilkas. He gives you a random quest, then he gives you his Purity quest (Remember to have the heads in your inventory). Decline his Purity quest. If Farkas doesn't give you any quest after that, take an Aela's random quest and complete it. This will unblock Farkas random quest. Do it and then complete his Purity quest. When thats done, Vilkas will complete his Purity quest without a problem.

  • After you complete Purity with either Farkas or Vilkas , if you immediately go talk to the other one, sometimes the quest will show up in your completed quest section, and you will not be able to activate the altar in Ysgrammor's tomb. This can be solved by loading a save state from before you accepted the first Purity mission, re-completing it, then doing another mission. Any mission should do, you can take an Animal Extermination mission from Aela that does the job nicely. After doing another mission, talking to the second of the two brothers starts the mission the way it's supposed to and you can complete it, making both Farkas and Vilkas very happy with you.

Hope that helps :)

  • This worked for another bug as well: Vilkas doesn't start the "Is it over?" conversation after killing the spirit. I had to do a random Aela quest, then Farkas' Purity, then random Aela, random Vilkas, and finally Vilkas' Purity.
    – l0b0
    Mar 28, 2015 at 22:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .