My wife has an eight year old computer we're building a replacement for. Recently, Hades started to a black screen with a cursor; and Cat Quest 2 claimed no graphics card was installed.

I replaced the previous GTX 950 with a GTX 1660, replaced the PSU with a new one, and updated Nvidia graphics drivers to version 515. Unfortunately, this is all still happening.

It is the only thing on the machine, which I know of, to have issues of any kind. The 1660 is in perfect health. I recently used that same card to play Hades through to the end, on a different machine, running the same OS.

Problems go from a black screen with a cursor visible to outright failure to launch. Not that long ago, it was working fine. I know it isn't the GPU or the PSU. In the best case, she has a black screen, a cursor, and background music.

Does anyone have any ideas?

Addendum: Recently I managed to get Hades to a title screen, but only after along delay and a brief flash of what looked almost like CGA graphics. It was still unresponsive.

Addendum: Now that said computer is reassembled, I used NVIDIA's prime-select to ensure that the desktop environment was set to use the actual graphics card, and not the iGPU. (This would be just as well, save that the games aren't seeing it.) It actually doesn't even detect the iGPU, possibly because it's an older AMD piece from around 2013 or so. Steam's system information also reports the correct card installed, and every other program runs flawlessly.

Addendum: My wife informs me that after setting Proton to use DirectX instead of Vulkan, and a considerable delay, it finally loaded and allowed her to play. This is a weird spot in an academic sense because I still don't know why it was refusing before. Additionally, possibly because of the DirectX setting, she has significant screen tear now; but it should hold her until her new machine is assembled.

That said, I don't consider the problem solved, because the game is still acting wonky (screen tearing) and I had no such problem using Vulkan on an almost identical machine, with the exact same hardware. So, I think the jury is still out on this one...

  • 2
    It can be a lot of things, unfortunately. Visual problems are not exclusively caused by the GPU or its drivers, but can you check if it uses the dedicated GPU at all, and not just the on-board one? You can check this through the Task Manager. Another option is to reinstall Hades and other affected games. If that doesn't work please update your post.
    – Joachim
    Aug 12, 2022 at 10:04
  • 2
    @Joachim I'm actually using Linux, which typically runs just about anything great these days; but I don't have the Windows task manager. However, I'm sure there's a way to check with something like systemctl —I used the command option /GpuIndex=1 just in case, and it had no affect, but it might be that my GPUs are being indexed in the wrong order and it was doing that anyway. I've also validated the game cache twice and come up with nothing. I'll be back when I've got more data. Aug 12, 2022 at 15:01
  • Have your graphics drivers changed in that period? Was there anything installed between the times where it worked and where it didn't work?
    – Corsaka
    Aug 15, 2022 at 10:05
  • @Corsaka There was one period over which she chose not to update her graphics drivers, and it occurred to me that Steam did continue to update and the new version of Proton might require something more recent from Nvidia. So, after the problem manifested, I updated the driver to the most recent (v. 515). Unfortunately it had no noticeable affect. Beyond that it's still something of a mystery; she doesn't recall changing anything intentionally. The game does validate successfully, so it's not that. Aug 15, 2022 at 13:54
  • 1
    How are you launching Hades? Steam with proton? Which version of proton if you do so? In the launch options are you using x64, x64 vulkan or x32?
    – Braiam
    Jan 8 at 4:14


You must log in to answer this question.

Browse other questions tagged .