I'm trying to connect my Nintendo DS to Internet, but my router have a WPA security, which isn't supported by the DS. So I'd like to create a hotspot to share my wifi at home, but with a WEP security or no password at all.

I tried to use my Windows laptop but it requires a password. I also attempted to use Powershell with these two commands:

netsh wlan set hostednetwork mode=allow ssid=anything key=
netsh wlan start hostednetwork

but the second command writes "Group or resource isn't in the correct state to perform required operation" (this may not be the exact error message, it's a translation of mine).

I downloaded some mobile apps too, but none has provided a way to create an open hotspot or to change the security level to WEP. So currently I'm using my mobile data, but I have a bad connection (which doesn't work often) and I don't want to apply some obscure changes to my router in order to modify the security. Does someone have an idea to help me?

  • 2
    Just for your information, WEP is very old and trivially easy to break, so it's possible that most modern access points simply do not support WEP at all. Also, I think you'll have more luck asking this on Super User instead.
    – Nolonar
    Commented Sep 9, 2022 at 18:37
  • @Nolonar Maybe it'd be better received at Network Engineering, I'm not sure though.
    – Skye-AT
    Commented Sep 9, 2022 at 20:05
  • @Skye-AT It wouldn't. Consumer hardware is explicitly off topic there. Super User is the best place, since this question doesn't seem to be actually specific to the Nintendo DS, and I would cast a close vote as off topic except I'm pretty sure almost nobody else would agree with me.
    – pppery
    Commented Sep 12, 2022 at 1:36
  • Agree you should not (and possible cannot) use WEP, but a guest network with no password is OK. Commented Jul 4, 2023 at 0:27

2 Answers 2


I have your same problem. You get that error because your configuration does not support hosted networks, or simply you don't have the specific driver.

You can check this typing in an admin command prompt:

netsh wlan show drivers

which leads to:

Hosted network supported: No

If that's the case, unfortunately, it's related to your Network adapter or Windows 10 itself (if you run that), which doesn't support Microsoft Hosted Network Virtual Adapter that Windows 8 used to have.

Here are some solutions I found online:

  • Downgrade your Wi-Fi adapter drivers to a previous version (Windows 8.1 for example), that should make "Microsoft Hosted Network Virtual Adapter" appear again.

  • From "Registry editor":

    1. locate HKEY_LOCAL_MACHINE\system\currentcontrolset\services\wlansvc\parameters\hostednetworksettings
    2. set EverUsed value to 1
  • From "Services":

    1. find "WLAN AutoConfig"
    2. start it if stopped
    3. set "Automatic" as Startup type
  • From "Device Manager":

    1. search for the "Network Adapter" drivers
    2. right click on it and then select "Update Driver Software"
    3. select the option 'Browse my computer for driver software'
    4. and 'Let me pick from a list of device drivers on my computers'
    5. uncheck the option 'Show compatible hardware'
    6. under the Manufacturer select "Microsoft"
    7. search for 'Microsoft Hosted Network Virtual Adapter' and follow the instructions

If nothing works you can still use the integrated Windows Mobile Hotspot, by sharing your Internet connection with other devices over Wi-Fi:
Settings > Network and Internet > Mobile Hotspot

  • Thanks for your reply, I did some research before but didn't find what you wrote. I don't really want to modify my drivers, so I think I'll continue doing as today, by sharing my mobile data because I'm not sure I'll continue to play online with my NDS, it was more a try, otherwise I'll follow your instructions.
    – Chi_Iroh
    Commented Sep 10, 2022 at 16:33
  • I get your point. Have you tried the integrated Win10 mobile hotspot?
    – pinckerman
    Commented Sep 10, 2022 at 17:00
  • Your comment has just made me realize how this sentence was unclear : "I tried to use my Windows laptop but it requires a password", because I intended to say that I used this functionnality but I couldn't create a hotspot without password, and obviously the security cannot be changed and isn't compatible with my NDS.
    – Chi_Iroh
    Commented Sep 10, 2022 at 19:45
  • Oh well, bummer...
    – pinckerman
    Commented Sep 10, 2022 at 20:07

The only solution that I've found is to start a Guest Network through my router without security for the small window in which I need to use WiFi within a DS game. This is only an issue for games developed for the DS, DSi and above titles will support WPA.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .