I cannot understand why my transformer does not work. It says disabled by automation grid, but it's not connected to that grid. I have tried disabling it and enabling it, and I have tried deconstructing it and rebuilding it.

See pictures below




  • Note that on your second screenshot, it's the automation port shows red (disabled) and not white (not connected). While in automation overylay, click 'x' and click that tile. A task will be given to a duplicant to deconstruct the single piece of automation wire you have there. Commented Sep 6, 2023 at 17:19

2 Answers 2


Your second screenshot shows the automation port on the transformer highlighted red. That means the game thinks it's connected to an automation wire.

Almost certainly you have a single square of automation wire there not connected to anything else (which is therefore drawn as a small square that is entirely obscured by the port, even in the automation overlay - only the highlight of the port reveals its presence). An automation wire "sends" red by default, even with nothing connected that can send a signal, so if you previously had some automation there and deconstructed all the wires you could see (accidentally excluding the tile of wire hidden behind the port), the transformer will be permanently reading red on its automation port and will be disabled forever.

It's a mistake I have made a number of times! You need the tile with the automation port to have no wire, in order to revert to non-automated behaviour. Try opening the automation overlay and issuing a deconstruct order for that tile.


I deconstructed it again and rebuilt it a bit to the right of the previous location and then it worked. I have no idea about why.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .