0

I am trying to make an addon which adds the rascal to Minecraft BE. I have been trying to allow users to use older versions of the mob geometry with the subpacks feature. However, the subpack slider does not seem to have any effect. In fact, no files in subpacks are being loaded. Here is my manifest.json, and my file structure (I have already tried one other previously).

{
  "format_version": 2,
  "header": {
    "name": "Rascal: §8Textures",
    "description": "Contains the required textures, models, and animations for Rascal",
    "uuid": "44caf057-1fcd-4eb9-9564-05ae75112ab7",
    "version": [
      2,
      0,
      0
    ],
    "min_engine_version": [
      1,
      19,
      31
    ]
  },
  "modules": [
    {
      "description": "textures",
      "type": "resources",
      "uuid": "a884ed44-162c-4532-81a3-bd65bf9a9eca",
      "version": [
        1,
        0,
        0
      ]
    }
  ],
  "subpacks": [
    {
      "name": "Geometry v2",
      "folder_name": "v2",
      "memory_tier": 0
    },
    {
      "name": "Geometry v2.1",
      "folder_name": "v2_1",
      "memory_tier": 0
    }
  ]
}
├── manifest.json
├── subpacks
│   ├── v2
│   │   ├── models
│   │   └── textures
│   └── v2
│       ├── models
│       └── textures
└── entity

The entity file references geometry.rascal which is the identifier in both models folders. It also references textures/entity/rascal which is present in both textures folders.

0

You must log in to answer this question.

Browse other questions tagged .