3

For the past few months I have been having an issue with Steam, and I have finally decided to ask about it. I've looked up solutions but none of them work, and nobody else has seemed to have had the same problem.

The issue:
Any time I try visiting a page (except for my Library page for some reason) Steam will give me this error: Error Image Apparently nobody I can find has had the same issue. I can't contact Steam support because their support email is down apparently and if I try filling out the form, it gives this same error. If I try using it on my browser it says that the URL isn't secure. I have made sure the URL is correct too.

Things I've tried:
Clearing my Cache
Reinstalling Steam
Restarting my system
Much more other stuff, the list could go on.

If you need details on my system info, please ask me for the specific information you need. You can also ask if you need more details on the error or anything else.

Edit for time sync answer:
I tried out the answer (sync my time) given to me by a user but it didn't work, still gives me the error.
Time Sync Image

At the same time I tried looking at more info for the issue and when I looked at the certificate details it says it was issued on "Tuesday, December 21, 2021 at 6:00:00 PM", and expires on "Wednesday, December 21, 2022 at 5:59:59 PM". So it's not expired.
Certificate Info

I have also checked out the more information tab on the security warning my browser gives me, it says it may be due to a network attack but I highly doubt it, I even ran malware scanners and checked with other sites/devices connected to the network and this problem doesn't happen with the other stuff. Other browsers I tried also give me the same warning.
Opera GX Warning

Edit for certificate checking and stuff:
I went through and checked if the certificate is in the list of trusted authorities, and it is.
Digicert Appears
However if I try to open it, it will give me this error before letting me continue.
Digicert Error
The thumbprint (5fb7ee0633e259dbad0c4c9ae6d38f1a61c7dc25) matches the one given to me by @user1558321, but I did notice that when I look at it four of the things have a special icon on them, two are yellow warnings and two look like download symbols.
Errors/Downloads
I think it might be something to do with the error below, but I don't know how to give it a valid signature or pathway.
Invalid Signature
Post note: This answer did work, I just accidentally did something wrong and forgot to remove the old invalid certificate from my PC!

0

3 Answers 3

4

As the time and date answers did not seem to help you it is signaling that something is quite wrong with your computers certificate store and the root certificate for DigiCert ('DigiCert High Assurance EV Root CA') is missing (or you might have some malicious applications on your computer)

First, we can try seeing if the 'DigiCert High Assurance EV Root CA' is part of your computers trusted root certification authorities. This certificate authority should be present in default Windows installations.

  1. Hit Win+R key on your keyboard. In the new 'Run' window enter certmgr.msc and hit ok.

Run certificate manager

  1. In the new window, using the navigation pane on the left navigate to 'Trusted Root Certification Authorities' -> 'Certificates'. We can confirm that the certificate is present by looking at the list enter image description here

  2. If we double click on this certificate and navigate to the details tab we can check the thumbprint of this certificate. According to DigiCert website's information the correct thumbprint for this exact certificate is '5F:B7:EE:06:33:E2:59:DB:AD:0C:4C:9A:E6:D3:8F:1A:61:C7:DC:25'. You can see that it is an exact match if we remove the colons used for formatting.

enter image description here

If the 'DigiCert High Assurance EV Root CA' certificate is missing from the list then there might be a problem with your Windows installation as in a default installation Windows Update should take care of keeping this list up to date. I would highly suggest trying to run Windows Update and getting the newest patches from Microsoft. There might be possibility that a GroupPolicy setting is set on your computer (should not by default) that disables these trusted certificate list updates. To check this:

  1. Hit Window+R keys on your keyboard, enter gpedit.msc

  2. In the Group Policy window navigate to Computer Configuration -> Administrative Templates -> System -> Internet Communication Management -> Internet Communication settings.

  3. In this view find the setting 'Turn off Automatic root certificate updates'. If everything is correct it should be set to 'Not Configured' or 'Disabled'. If It is enabled, set it to Disabled, hit OK and restart your computer, then try running windows update.

enter image description here

This next step is for experimentation sake. Only Windows Update should be trusted with installing root certificates unless you have a direct need yourself

If all else fails you can try installing this root certificate manually. Download the 'DigiCert High Assurance EV Root CA' certificate from DigiCerts website manually (since your browsers are blocking access to websites with DigiCert based certificates you might need to do this step on another device and transfer the file to your computer).

  1. On the website find the exact Certificate that we need ('DigiCert High Assurance EV Root CA') and press 'Download DER/CRT'.

  2. Open the downloaded file and a certificate pop up should appear. Hit 'Install Certificate'.

  3. Follow these steps: select 'Local Machine' as the store location. In the Certificate Store step select 'Place all certificates in the following store' and click browse. In the list select 'Trusted Root Certification Authorities' folder and click ok.

  4. Finish the installation. After that restart your computer and check if a difference was made

4
  • I went through and checked to see if the certificate was there, it is, and the thumbprint matches. But it is saying "The integrity of this certificate cannot be guaranteed. The certificate may be corrupted or have been altered" Commented Nov 5, 2022 at 0:54
  • I also went and looked, two of the icons have a yellow warning sign, which I don't know how to fix :/ Commented Nov 5, 2022 at 0:55
  • Fast forward 4 hours later, I tried installing the certificate to see what would happen, nothing changed... Commented Nov 5, 2022 at 5:47
  • 1
    Oh my god I forgot to delete the old certificate that was invalid before reinstalling it so it didn't work and when I realised I forgot to I deleted it then reinstalled it and it worked! I can access my steam again. Tysm to everyone that helped to solve this problem! Commented Nov 5, 2022 at 15:17
4

When you connect to the Steam page, your browser/Steam client checks the SSL certificate that is provided by the Steam page. Steam's certificate is provded by DigiCert who is a trusted certificate authority and does not seem to have any problems with their certificates at the time of writing this answer. Steams certificate chain If you did not change anything in your computer regarding certificates it should be trusted.

That means the problem is in your computer configuration. Now a common problem which could cause problems in certificate validation is the certification expiration check. When your computer validates a certificate it will compare it's expiration date with your computer time. As a first step, please check If your computer time and date is correct. Sometimes even a few minute error with the actual time could cause certificate validation problem.

(I'm starting with this approach because I did notice that a few months ago you asked a question regarding changing your computer date for a Minecraft April fools event)

1
  • @user1558321 unfortunately it didn't work, I synced my time and it is still giving me the SSL certificate error Commented Nov 3, 2022 at 22:13
1

The error you're getting is "NET::ERR_CERT_AUTHORITY_INVALID": this means that although the Steam certificate itself is valid, your computer doesn't consider the signature on the certificate to be valid.

The most common cause of this is that your clock is wrong, and your computer thinks the signature is either from the future or too far in the past.

Another cause, less common, is that your computer doesn't know about the certificate authority that signed the certificate. DigiCert, the company that signed the Steam certificate, has been around for decades, so this is unlikely. Even so, try updating Windows to see if you pick up any new certificate authorities.

A third possibility is that your internet service provider is interfering with your connection to Steam.

2
  • I already ruled out that it was my clock being wrong since I already synced it a bit ago, I highly doubt (but can't confirm my doubt so it's not out of the question) that my provider is interfering, but I now suspect it is because my PC doesn't know Digicert for some reason. I went to their website (which they use their own certificate for apparently after checking) and my PC said the same thing it is for steam, invalid certificate. I'll see if my PC needs updates or something and tell you how it goes. Commented Nov 3, 2022 at 23:27
  • Hey so it's not because my PC doesn't know about DigiCert or because an update is in the way, I determined it's because the Certification Signature is invalid, and I don't know how to fix it. Installing the certificate from their site didn't fix it :/ Commented Nov 5, 2022 at 5:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .