3

I have been trying to run God of War on my PC, but it crashes within one to two minutes of playing. The "bug splat" from the game says that my GPU may be the issue and suggests that I update my drivers, make sure the GPU isn't overheating, and/or remove any overclocks. The splat also says that the error reason was my device was removed (the GPU) with reason "device hung".

So far I've done:

  • Updated my Nvidia Graphics Driver (using 527.56 528.24 currently).
  • Removed my GPU overclock.
  • Removed CPU and RAM overclocks (turned off D.O.C.P. and reverted RAM speed to default).
  • Uninstalled the game and reinstalled (to a faster drive as well).
  • Verified game files using Steam (though this didn't seem to work - it got stuck at the 6% mark for a while, but a full reinstall should basically take care of this too).
  • Updated my motherboard BIOS.
  • Tried running the game with all graphic settings set to low.
  • Closed MSI Afterburner (that worked for me before once on a different game).
  • Performed a System File Checker scan using sfc /scannow
  • Also since posting this question, I've sent my GPU back to the manufacturer via an RMA to which they found nothing wrong (I only did this because I had some other hardware issues).

If I check Windows Event Viewer, this is the captured error:

Faulting application name: GoW.exe, version: 1.0.475.7534, time stamp: 0x628e8031
Faulting module name: GoW.exe, version: 1.0.475.7534, time stamp: 0x628e8031
Exception code: 0xc0000005
Fault offset: 0x0000000000993880
Faulting process id: 0x0x2CF8
Faulting application start time: 0x0x1D8FA31292E1B4A
Faulting application path: M:\Steam\steamapps\common\GodOfWar\GoW.exe
Faulting module path: M:\Steam\steamapps\common\GodOfWar\GoW.exe
Report Id: b0919472-7bc2-47ec-bf7f-892d06adfae7
Faulting package full name:
Faulting package-relative application ID:

The only information I've been able to find so far are some Reddit posts that don't have any conclusive solutions. How can I prevent God of War from crashing?

Hardware Information:

  • Gigabyte RTX 3080Ti GPU
  • AMD Ryzen 7 5800X CPU
  • 16Gb of DDR4 3800 RAM
  • ASUS ROG Crosshair VIII Hero Motherboard

January 30th 2023 Update:

After trying the latest Nvidia driver, I tried again. The game still crashes. I decided to look in the installation directory and found the .dmp file of the crash. I installed WinDbg to try and peek into the .dmp file. After running !analyze -v, a bunch of information is displayed. This is a bit deeper than my knowledge goes on debugging, but I think the relevant information from the tool is the following:

EXCEPTION_RECORD:  (.exr -1)
ExceptionAddress: 00007ff9cc1d06bc (KERNELBASE!RaiseException+0x000000000000006c)
   ExceptionCode: e0000d11
  ExceptionFlags: 00000081
NumberParameters: 3
   Parameter[0]: ffffffff887a0005
   Parameter[1]: 00007ff6244f67e8
   Parameter[2]: 00007ff6244f47e0

PROCESS_NAME:  GoW.exe

ERROR_CODE: (NTSTATUS) 0xe0000d11 - <Unable to get error code text>

EXCEPTION_CODE_STR:  e0000d11
EXCEPTION_PARAMETER1:  ffffffff887a0005
EXCEPTION_PARAMETER2:  00007ff6244f67e8
EXCEPTION_PARAMETER3:  00007ff6244f47e0

STACK_TEXT:  
000000fe`5ee6fcc0 00007ff6`2406b265     : 00000295`0860c710 00000297`851ca010 00000000`00007250 00000000`00000000 : KERNELBASE!RaiseException+0x6c
000000fe`5ee6fda0 00007ff6`24054f69     : 00000295`168ea5e0 00007ff6`243bac27 00000295`168ea6a0 00007ff6`2488f9e0 : GoW!agsSetDisplayMode+0x5c89b5
000000fe`5ee6fdf0 00007ff6`243babcd     : 00000000`00000000 00007ff6`2488fca0 00000000`00000000 00000000`00000000 : GoW!agsSetDisplayMode+0x5b26b9
000000fe`5ee6fe50 00007ff9`cbe39363     : 00000295`25ddb9a0 00000000`00000000 00000000`00000000 00000000`00000000 : GoW!ffxFsr2GetJitterOffset+0x33979d
000000fe`5ee6fe80 00007ff9`cdd826bd     : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : ucrtbase!thread_start<unsigned int (__cdecl*)(void *),1>+0x93
000000fe`5ee6feb0 00007ff9`ce74dfb8     : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : KERNEL32!BaseThreadInitThunk+0x1d
000000fe`5ee6fee0 00000000`00000000     : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : ntdll!RtlUserThreadStart+0x28

SYMBOL_NAME:  gow+5c89b5
MODULE_NAME: GoW

This gave me the idea of attaching a debugger (WinDbg) to the game executable when it's running, so I tried that. I played the game until it crashed (about 2 minutes in), and this was reported in the tool:

(2e00.1f6c): Break instruction exception - code 80000003 (first chance)
ntdll!DbgBreakPoint:
00007ff9`ce792af0 cc              int     3

D3D11: Removing Device.
ModLoad: 00007ff9`c4c30000 00007ff9`c4ce0000   C:\Windows\SYSTEM32\TextShaping.dll
(2e00.4b78): Access violation - code c0000005 (first chance)
First chance exceptions are reported before any exception handling.
This exception may be expected and handled.
GoW!agsSetDisplayMode+0x5b0fd0:
00007ff6`24053880 890c2500000000  mov     dword ptr [0],ecx ds:00000000`00000000=????????

I am wondering if whatever agsSetDisplayMode is the issue. Researching this, I found this page, but this seems to be about AMD Graphics , which my computer does not have (Googling this word returns a lot of results mentioning AMD), so I don't know if its correct or not (nor what it even really is). The page says its "The struct to specify the display settings to the driver."

11
  • As of yesterday (in my timezone) Game Ready Driver's newest version is 526.98, perhaps you should try that. I can't say for sure since I don't have GoW on PC, but when I had same (ish) error on Divison 2, completely wiping the GPU driver with Display Driver Uninstaller and performing clean install the GPU driver has solved the issue. Maybe worth a try. ... Completely unrelated, but M drive!? How many drives do you have...?
    – Skye-AT
    Commented Nov 17, 2022 at 19:00
  • @Skye-AT I'll see about trying that. I have a feeling the GPU driver is completely crashing because when the game crashes, other thing on my computer appear all bugged out and blacked out. And 5 drives total. I chose random letters :) (C:, D:, H:, L:, M:)
    – Timmy Jim
    Commented Nov 17, 2022 at 19:05
  • @Skye-AT I uninstalled my Nvidia driver completely, and then installed 526.98. The game still crashed unfortunately, darn near instantly too. I got a different error it seems though captured in Windows Event viewer: i.sstatic.net/mLCpX.png
    – Timmy Jim
    Commented Nov 18, 2022 at 2:29
  • Hmm. Any chance you've got any other GPU? Not GoW (and not even a game), but I once had same dll was causing exact same issue (fwiw, here's link (adobe's website) that explains the issue and how to solve). Not sure if this applies to game, though.
    – Skye-AT
    Commented Nov 18, 2022 at 3:06
  • @Skye-AT I do not have another GPU, not even an integrated one. I'm starting to run out of options it seems :/
    – Timmy Jim
    Commented Nov 18, 2022 at 3:12

1 Answer 1

2

Unfortunately, after many driver updates and trying a ton of other things, the only thing that worked was a costly hardware replacement. I replaced my GPU and the issue is no longer present. The game seems to run fine now.

It's odd because my former GPU worked fine with many other games, but some games (notably Payday 3) would also crash with a similar error of claiming that the DirectX device was lost/disconnected/hung. I've had other games seemingly randomly crash, but I've attributed those random crashes to just that (but there's a very good chance it could have been the GPU in those cases as well).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .