Does anyone know if, and how, you can successfully launch a non-Flatpak version of Discord from Steam on the Steam Deck without putting the deck into developer mode?

I've installed the Flatpak version of the application and added that to Steam as a Non-Steam game, and I can launch that fine from Steam, both in Desktop and "Gaming" mode. I've also downloaded the application in a tar.gz and extracted that. I can run that application in Desktop mode, outside of Steam without issue. I also moved the application file to a place I know Steam can access (~/.local/share/Steam/steamapps/nonsteam/discord) and altered the .desktop file appropriately and put that in ~/.local/share/applications. I tried launching the application outside of Steam again, and that worked fine. When trying to launch it from Steam, however, Steam shows that the application immediately closes.

I've tried setting the application to use the default runtime and Steam Linux Runtime; same result.

I've also tried to see if any errors are produced by changing the launch option to %command% >> discordsteam.log but the created file after launching the application is completely empty.

  • Why not use Discord from the browser in desktop mode?
    – Neon1024
    Commented Nov 25, 2022 at 11:12
  • Browsers are also installed as a Flatpak, @Neon1024 , and the experience of Firefox in Gaming mode is awful as the cursor frequently "misbehaves". And if I'm using Flatpak, (which I currently am) why would I choose the browser version over Discord's official Flatpak application? The key thing is I want to use the non-Flatpak version.
    – Larnu
    Commented Nov 25, 2022 at 11:14
  • Which version of Discord gets installed when you use the SteamOS Discover Store?
    – Stevoisiak
    Commented Jan 6, 2023 at 19:57
  • Flatpak, @Stevoisiak .
    – Larnu
    Commented Jan 6, 2023 at 19:59
  • Does the non flatpak version work in gaming mode if you disable hardware acceleration and desktop notifications?
    – Stevoisiak
    Commented Jan 6, 2023 at 20:01

1 Answer 1


Just got my Steam deck and I am dealing this problem for a few days. Here’s how I solved it.

Create a text file named discord Input those below

unset LD_PRELOAD                                                                
exec /usr/share/discord/Discord

Save it and make sure it is executable Is Executable Finally, Add the file to Steam and that it. Hope this can solve your problem.

This way can deal with any programs install from pacman/yay.

  • Gave this a go, but the non-flatpak version of the application still fails to launch via Steam; launches fine outside of it.
    – Larnu
    Commented Dec 29, 2022 at 10:35
  • I am using non flatpak as well, and it works for me. You can try to put your discord folder at /usr/share.
    – e2ne0
    Commented Dec 29, 2022 at 17:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .