Every time I connect to my Windows 10 PC from my phone using Windows Remote Desktop, Nvidia ShadowPlay gets disabled. Enabling it from the game overlay (Alt+Z) will immediately turn it off again.

As a bodge fix, I'm running a batch script that restarts the culprit NVIDIA LocalSystem Container Windows service, which prevents ShadowPlay from being manually enabled.


NET STOP "NVIDIA LocalSystem Container"
NET START "NVIDIA LocalSystem Container"

It takes a while for the service to be restarted by the script and you still have to manually turn ShadowPlay back on after this, which I often forget, so it's far from an ideal solution.

I'm not sure whether or not it may get disabled due to the resolution changing or for safety reasons, but as I've securely configured my network I'm wondering if anything could be done to combat this. I'd prefer sticking to Windows Remote Desktop.


You must log in to answer this question.

Browse other questions tagged .