3

Whenever I try to run Metro Exodus, I receive this error:

H:\SteamLibrary\steamapps\common\Metro Exodus Enhanced Edition\AnselSDK64.dll is either not designed to run on Windows or it contains an error. Try installing the program again using the original installation media or contact your system administrator or the software vendor for support. Error status 0xc0000603.

This happens with either the enhanced PC edition (that features ray tracing), or the regular edition of the game. I know that Ansel is suppose to be for taking high quality screenshots of games, which is a feature I actually don't use, but nevertheless, Metro Exodus must have a dependency on this .DLL and is refusing to run because of it (and I checked the directory location of the .DLL to verify it exists).

I've tried:

  • Installing both versions of the game (enhanced edition and regular) to see if either would work
  • Verified the game files using Steam
  • Reinstalling the game(s)

I have an RTX 3080Ti graphics card which supports ray tracing, and my display driver is up to date (527.56). What is odd is I use to be able to run this game (albeit it would crash on occasion), but due to some hardware issues, I had to reinstall Windows on a new disk, and since reinstalling both Windows and the game (since the game itself was on a different hard drive that also died), this error happens.

How can I correct this?

I should note that when I click the "Play" button using Steam, the game refuses to start and the error doesn't display. I have to navigate to the Metro Exodus game executable in File Explorer and try to run it from File Explorer to get the error to display.

5
  • I think the fact that it doesn't run at all when launching through Steam is the larger problem, as most Steam(-enabled) games require it running (maybe the Ansel dll doesn't run properly when not run through Steam). Can you check if the executable shows up at all in the Process Monitor?
    – Joachim
    Dec 29, 2022 at 14:00
  • And can you try downgrading the drivers? The latest drivers caused several BSODs for me (although my GPU is significantly older, and likely requires other drivers).
    – Joachim
    Dec 29, 2022 at 14:02
  • @Joachim If you mean this process monitor, I found some results for the executable, but none of it makes sense to me. There is ALOT of stuff in this tool. Here is just a fraction of some it: i.stack.imgur.com/Qcj2o.png I have not tried older drivers, but as I said I had this running before my hardware mishaps, and I believe I was using the same driver then, or one that isn't much older at least.
    – Timmy Jim
    Dec 30, 2022 at 1:44
  • They tend to update drivers every two weeks or so, and a new version can seriously change performances and introduce errors. And I was actually just referring to the standard Windows Ctrl-Shift-Esc thing, but couldn't remember the name (and I think my laptop is dying). Oh yeah, Task Manager 🙄
    – Joachim
    Dec 30, 2022 at 19:51
  • 1
    @Joachim I checked task manager first as well since I thought maybe that was what you meant, and the executable is not found in the list
    – Timmy Jim
    Dec 30, 2022 at 20:09

1 Answer 1

3

I ended up moving the game off of my H: drive to a different drive, and now the game starts without erroring.

My H: drive is a new NVME drive that supports PCI Express 4.0. The drive I moved the game to is a standard SSD drive. I don't know if this was the issue or not. What made me move the installation folder of the game was when I researched some of the errors I found in Process Monitor (see this image - in particular, the "INVALID DEVICE REQEST" errors), it lead me to this page which was about disk cluster sizes.

I think the only way to change these disk cluster sizes is by formatting a disk. While I could do this, I didn't want to since it would make me lose any data on the disk, but this gave me the idea of simply moving my game to a new drive. Upon doing so, the game now runs.

2
  • Glad to see you got it sorted out. Then indeedAnsel compatibility wasn't the real issue, I guess. Strange, nevertheless, that the game simply didn't start..
    – Joachim
    Dec 31, 2022 at 9:42
  • very interesting to see cluster size might lead to an assembly not being loaded properly
    – DrFish
    Jan 10, 2023 at 8:06

This site is temporarily in read-only mode and not accepting new answers.

Not the answer you're looking for? Browse other questions tagged .