So I just purchased The Stanley Parable so I can try the game out for myself without having to... go on some sketchy website and download it.

And after purchasing it, I installed the game, boot the game up, and it was playing fine... until a few minutes later when it suddenly hang up. No error messages, it just... crash without a reason.

Trying to find out why it crash, I ran Steam using the terminal so I can see the log. But unfortunately, no error messages showed up when the game hang.

After some digging on the Internet, I tried out some workaround like:

  • Setting the game to a lower resolution
  • Deleting the bin/libstdc++.so.6

But still, nothing changed. Game still hang up after few minutes of playing.

I'm guessing this is a problem with the Source engine that the original game was written in, cause The Stanley Parable: Ultra Deluxe launched and work just fine without any sort of issues.

Or it might just be because my computer is missing some weird dependencies which the game needed after.

I mean, it is an 9 years old game now, so maybe it's so old that it might need some patch. So what this problem might be?

Information: Steam was installed from FlatHub System information:

Computer Information:
    Manufacturer:  Dell Inc.
    Model:  0R2XKN
    Form Factor: Desktop
    No Touch Input Detected

Processor Information:
    CPU Vendor:  GenuineIntel
    CPU Brand:  Intel(R) Core(TM) i3-7020U CPU @ 2.30GHz
    CPU Family:  0x6
    CPU Model:  0x8e
    CPU Stepping:  0x9
    CPU Type:  0x0
    Speed:  2300 Mhz
    4 logical processors
    2 physical processors
    HyperThreading:  Supported
    FCMOV:  Supported
    SSE2:  Supported
    SSE3:  Supported
    SSSE3:  Supported
    SSE4a:  Unsupported
    SSE41:  Supported
    SSE42:  Supported
    AES:  Supported
    AVX:  Supported
    AVX2:  Supported
    AVX512F:  Unsupported
    AVX512PF:  Unsupported
    AVX512ER:  Unsupported
    AVX512CD:  Unsupported
    AVX512VNNI:  Unsupported
    SHA:  Unsupported
    CMPXCHG16B:  Supported
    LAHF/SAHF:  Supported
    PrefetchW:  Unsupported

Operating System Version:
    Freedesktop.org SDK 22.08 (Flatpak runtime) (64 bit)
    Kernel Name:  Linux
    Kernel Version:  6.0.15-300.fc37.x86_64
    X Server Vendor:  The X.Org Foundation
    X Server Release:  12014000
    X Window Manager:  GNOME Shell
    Steam Runtime Version:  steam-runtime_0.20221019.0

Video Card:
    Driver:  Intel Mesa Intel(R) HD Graphics 620 (KBL GT2F)
    Driver Version:  4.6 (Compatibility Profile) Mesa 22.2.4 (git-80df10f902)
    OpenGL Version: 4.6
    Desktop Color Depth: 24 bits per pixel
    Monitor Refresh Rate: 59 Hz
    VendorID:  0x8086
    DeviceID:  0x5921
    Revision Not Detected
    Number of Monitors:  1
    Number of Logical Video Cards:  1
    Primary Display Resolution:  1366 x 768
    Desktop Resolution: 1366 x 768
    Primary Display Size: 13.54" x 7.64" (15.51" diag)
                                            34.4cm x 19.4cm (39.4cm diag)
    Primary VRAM Not Detected

Sound card:
    Audio device: Realtek ALC3246

    RAM:  7681 MB

VR Hardware:
    VR Headset: None detected

    UI Language:  English
    LANG:  en_US.UTF-8
    Total Hard Disk Space Available:  227311 MB
    Largest Free Hard Disk Block:  177813 MB

    Number of SSDs: 3
    SSD sizes: 240G,240G,0B
    Number of HDDs: 0
  • 1
    The Ultra Deluxe version use Unity instead of Source.
    – Quan
    Dec 31, 2022 at 12:09
  • Are you running it via Proton? Deleting bin/libstdc++.so.6 is only recommended if you're running native, according to the ProtonDB page: protondb.com/app/221910
    – Dr-Bracket
    Jan 11 at 7:32
  • I'm running the game natively, and I've already tried deleting the file, but it did no help. Also I read that it's used to fix the game hang up on startup, not hang up after few minutes of playing
    – Quan
    Jan 12 at 11:29
  • Does the game work if you play via Proton?
    – Dr-Bracket
    Jan 12 at 15:07
  • well yeah, it does work
    – Quan
    Jan 14 at 4:59

1 Answer 1


Per the question comments, OP confirmed the game runs if played via Proton

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .