I cleaned the Xbox 360 internal hard drive with the Linux "dd" command:

dd if=/dev/zero of=/dev/sdc

After this the drive is no longer recognised by the Xbox 360 (the drive doesn't show up in System->Storage Devices).

Is there anything I can do to make the drive usable with Xbox 360 again?

I have tried to create an exFAT partition on it but it did not help.

  • 2
    What are you trying to do exactly? I'm not sure if this should be tagged with homebrew or not, but it certainly doesn't sound like a normal Xbox 360 thing...
    – Timmy Jim
    Jan 18, 2023 at 17:11
  • Just tried to empty the hard drive before giving the device to someone else. Maybe a bit harsh way, but anyway, would like it back :)
    – Mike
    Jan 18, 2023 at 19:56
  • This is a poweruser action but certainly not homebrew
    – Schism
    Jan 19, 2023 at 3:36
  • You've wiped the entire disk including the partition table. You need to re-partition it to what the XBox is expecting, but I don't know what that is.
    – OrangeDog
    Jan 19, 2023 at 12:19

1 Answer 1


Perhaps you need to partition and initialize the drive with certain predefined Xbox 360-specific FATX volumes. That's how you do it on the original Xbox.


I use FatXplorer for original Xbox drives myself, but it seems to be mainly made for the 360. It should be able to initialize the drive for you.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .