I have installed GTA 1 (published in 1997) from the original disk onto my Dell Inspiron 7580 laptop (Windows 10). I have created an .MDX file and am using Daemon Tools Lite to run the game without having to have the game on a disk drive.

The game runs, but the game runs excessively fast. If I use the game's inbuilt framerate limiter (F8 on its standard control layout) the game is slowed but still runs 'fast' with control being very hard.

I have reduced the refresh rate of the laptop from 60 Hz down to 48 Hz (the lowest native setting on the laptop), and while this has improved performance, it's still not as desired.

I believe that GTA 1 was designed to run at 25/30 FPS, so my current settings are nearly twice the originally designed requirements.

I'm looking for some way to reduce my laptop's framerate to 30 FPS or some other way of replicating the original system requirements for the game on the laptop.


1 Answer 1


I managed to run GTA 1 at its regular speed on Windows 10, on a laptop that has the same GPU as yours (Nvidia GeForce MX150). Here are the steps I followed and the settings I used to run it:

Note: I am using the version of GTA 1 that Rockstar Games previously offered for free on their website as part of their “Rockstar Classics Free Downloads Series” (along with Wild Metal and GTA 2). I believe that version is the same as the one currently available on Steam. You can also download it from the Internet Archive.

  • Install GTA 1.
  • Set <path to game>\GTA Settings.exe to run in Windows XP (Service Pack 3) compatibility mode. Then run it, and click 'Save'. (Otherwise, the game's executable, Grand Theft Auto.exe will output an error message when you try to run it.)
  • Download the Grand Theft Auto 1 & Grand Theft Auto London Patch bundle by Daniel Marschall.
  • Open All-In-One.zip and extract its contents: the scripts folder, ddraw.dll, and wndmode.ini to <path to game>\WINO (directory that contains Grand Theft Auto.exe).
  • Run <path to game>\WINO\Grand Theft Auto.exe. The Patch bundle should notify you of an update. Windows 10 might also ask you to install DirectPlay. Install the updates and DirectPlay, then quit the game.
  • In <path to game>\WINO, rename ddraw.dll as dinput.dll. (This allows us to install dgVoodoo 2’s files, which also include a ddraw.dll.)
  • Download the latest dgVoodoo 2 release.
  • In dgVoodoo2[version number].zip, extract dgVoodooCpl.exe, MS\x86\D3DImm.dll, and MS\x86\DDraw.dll to <path to game>\WINO.
  • Run dgVoodooCpl.exe and configure it using the following settings:
    • In the DirectX tab, under 'Videocard', select 'dgVoodoo Virtual 3D Accelerated Card' and set 'VRAM' to '128 MB'.
    • Under 'Behavior', uncheck: 'Application controlled fullscreen/windowed state' and "Disable Alt-Enter to toggle screen state'.
    • Under 'Miscellaneous', check 'Fast video memory access'.
    • In the 'General' tab, set 'Appearance' → 'Windowed' and 'Scaling mode' → 'Centered, keep Aspect Ratio'.
    • Click 'Apply' and 'OK'.
  • Run the game (Grand Theft Auto.exe). Once in-game, press F11 and choose '1024×768×32' as the resolution. This is the highest resolution supported by the game.

The game should run fine in windowed mode with these settings. I tried fullscreen mode first, but it caused stuttering and black screen issues, so I switched to windowed mode.

Let me know if you have any feedback on this configuration.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .