1

There is a Flash game, Castlevania: The Blood Way, which is hard to find on the internet today. One problem with that game is that it uses external resources: it loads SWFs from a specific domain, including level SWFs (0 to around 11 levels).

I've the SWF: https://drive.google.com/file/d/1YE-S8ynq_mscVC5dblHneWbCZ6o3-E8g/view?usp=share_link

But the game doesn't play anymore. I tested it in the Ruffle player a few months ago and it worked, but the game stopped working now. I believe that the external resources have expired. Note that it doesn't work in the Flash Player projector too anymore.

I used FFDec a few months ago and was able to manipulate these external resources, but I lost everything. For some reason, now that I go to FFDec, I don't have idea of what are the domains. For example, I see that FFDec shows this ActionScript 2 code:

loadMovieNum("musics/introB.swf",1,"GET");

The problem is, which is the base path for this resource? I tried to search for, say, musics/introB.swf in archive.org and didn't find anything. Not sure if this kind of search works in archive.org though. Any idea of what I'm missing? Because I was able to see the full absolute path of the resources...

3
  • I note the game appears to be available on BlueMaxima's Flashpoint. This may help you solve your setup problems.
    – pppery
    Feb 3, 2023 at 22:57
  • @pppery Thanks! I'm gonna try it tomorrow... BTW I think I exaggerated when I said it's hard to find on the internet, because I just searched for it and found it somewhere: coolstreaming.us/forum/arcade/game/12211.html I suspect it works in this site because the resources are there under www.coolstreaming.us? Of course when I try the same SWF in Ruffle or other places it doesn't work still.
    – Hydroper
    Feb 3, 2023 at 23:00
  • @pppery Yeah, it works in Flashpoint.
    – Hydroper
    Feb 4, 2023 at 11:53

1 Answer 1

1

As mentioned in the comments, Castlevania: The Bloodway is playable on BlueMaxima's Flashpoint Archive. It's listed as a demo, but I couldn't find evidence of a "full" version existing.

Castlevania: The Blood Way running in Flashpoint

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .