0

In Minecraft (Bedrock), I'm trying to replace water blocks with lava using a /fill command, e.g., on a region already containing water (note: this command covers the entire water region, there's no water left over around the edges):

/fill ~-3 ~-1 ~-3 ~3 ~-1 ~3 lava

But when I do this, instead of replacing the water with lava, it fills the region with obsidian :(.

It works the other way around, if I do this on a pool of lava:

/fill ~-3 ~-1 ~-3 ~3 ~-1 ~3 water

Then the lava is replaced with water. It's only when going water -> lava that it turns to obsidian.

I hand-wavily tried:

/fill ~-3 ~-1 ~-3 ~3 ~-1 ~3 lava 0 replace

But it had the same result: Obsidian instead of lava.

Is there a way to replace an area of water with lava with a command?

1 Answer 1

1

This is considered a bug: https://bugs.mojang.com/browse/MCPE-100607

The way I'd suggest working around this bug until it's fixed is to use an in-between fill of blocks that are otherwise not present in the area and that don't have any kind of world interaction with either water or lava (e.g. stone): replace the water with stone, then the stone with lava.

(Here an example using replace, but if you're just fully filling the area, you can remove the replace part)

/fill ~-3 ~-1 ~-3 ~3 ~-1 ~3 stone 0 replace water
/fill ~-3 ~-1 ~-3 ~3 ~-1 ~3 lava 0 replace stone

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .