1

I tried playing TDU 1 today (with the Project Paradise pack), and the game keeps freezing for a moment and then crashing to my desktop. After performing a number of trial and error tests, I realized it happens in one specific area on the map, and it's not even the most graphically demanding area. Even just selecting that section of the map to fast travel there causes the crash. I used to play the game a while back on this same PC before with no issues, and now when I try it out a couple of months later it's doing this.

My PC specs are:

OS: Windows 10 Home

RAM: 16GB

CPU: Intel Core i5-3570K 3.40GHz

Graphics Card: Nvidia GeForce GTX 1060 6GB

Running 2 Monitors

Troubleshooting I've performed:

  • Lowered in-game graphics to a bare minimum
  • Tried playing with only one monitor
  • Ensured drivers were up to date
  • Tried playing in Windowed mode
  • Tested with different cars (both original standard and Project Paradise issued)
  • Tried driving in different and more graphically demanding areas (no issues)
  • Tried different profiles to test for possible save corruption
  • Tried driving slowly through the problematic area (less than 60km/h)
  • Tried purging radical.cbd (saw this in another forum)
  • Tried with a newly created profile
  • Tried blocking internet connection on the firewall, and also completely disabling the firewall
  • Tried adding antivirus exclusions to the game folder and completely disabling my antivirus
  • Tried removing mods
  • Tried running just the standard TDU version (no mods and not with Project Paradise)

None of the above has helped me resolve the issue or determine the exact route cause. The only thing I haven't tried is re-installing and ideally I would like to avoid that. So before considering a fresh re-install, is there anything else I can look at to try get this issue resolved?

1 Answer 1

0

Okay, I managed to get it working without having to perform a complete re-install.

Since it was a CD-less copy, I found the original base game zip file and extracted it onto a different hard drive. I then followed the steps to install the Project Paradise pack, ensured my content and the Project Paradise install tutorial content was like-for-like, and not only could I travel to the problematic area, but my existing profiles were still usable and not corrupt.

I don't know what happened to the initial game folder location I was running from to cause the issue, maybe my AV deleted a file it wasn't happy with or something, but yea, the above solution worked for me.

1
  • Uh... CD-less copy that's in zip file? Maybe I'm overthinking this, but any chance you're running pirated version of TDU...?
    – Skye-AT
    Commented Mar 3, 2023 at 8:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .