I have a PC with the following specs:

  • AMD Ryzen 9 7950X 16-Core
  • Gigabyte X670E Aorus Master
  • DDR5 Corsair Vengeance 5200 MHz 32 GB
  • AMD Radeon RX 6800XT

It runs Windows 11 and I installed all the updates for Windows, and the latest drivers for the motherboard and the graphics card.

I bought this machine almost to run Microsoft Flight Simulator only. I bought the MSFS 40 Anniversary Edition on Steam, downloaded all the packages and the latest updates.

I have never seen the main menu yet, it always CTDs while loading it. Of course I tried many of the usual workarounds:

  • in Steam, verified the integrity of the files
  • ran MSFS in Safe Mode
  • ran MSFS as administrator
  • applied all the pending Windows Update items
  • uninstalled the AMD Adrenalin Drivers
  • installed the drivers (even older versions) again
  • set the virtual memory to fixed / automatic
  • uninstalled and installed MFSF again from scratch
  • formatted and installed Windows 11 again, as well all the software mentioned above
  • sfc /scannow
  • other things I don't remember now...

Looking in the Windows Event viewer I see the exception is 0x80000003.
I did a Google search without finding a clear explanation. Only the same list of trials I've already followed.

Would a GeForce RTX 4080 solve the issue? I mean, are Nvidia graphic cards more suitable for gaming?

  • 1
    @Joachim yes, I did. But to be sure I've just ran it twice. Nothing to report and same behavior of MSFS.
    – Mark
    May 12, 2023 at 13:02
  • From what you have listed there, your hardware is well-within (and probably above) the requirements for that game -- but this would not be the first time MS Flight Simulator has brought even a very good computer to its knees. I only have an RTX 3080, and it is just fine (it should be noted, the problem you are having is unknown, and changing the graphics card alone may not solve everything). May 12, 2023 at 15:24
  • @JonathanDavidArndt, is there a deterministic way to "debug" this issue and find out the real cause? I cannot believe there is no way to understand why a purchased application does not run at all...
    – Mark
    May 12, 2023 at 18:04
  • Actually, I learned one or two new troubleshooting techniques reading through this post (hence, it earns my vote). You've tried all the usual stuff. But yes! This is a popular commercial application! Perhaps the next step is contacting Steam support, followed by Xbox support. I will be just as interested in the solution as anyone. May 13, 2023 at 0:38
  • @JonathanDavidArndt unfortunately, Steam does not offer any support for Flight Simulator. They say you have to rely on the developer forum. Even the Steam forum is disabled for this product.
    – Mark
    May 15, 2023 at 11:00

1 Answer 1


Your problem is eerily similar to the one I just had (and fixed). In the course of my debugging I saw many things suggested, from the obvious ("reboot Windows!") to the absurd ("you have a faulty RAM stick!"). What I found which did turn out to help is this official (I think?) support troubleshooting list which, yes, does include "reboot Windows!", but also goes on to more esoteric things which the average user would not consider.

For me the one that worked (and I am still shaking my head at the stupidity of the necessity of this) was:


Microsoft Flight Simulator requires the English (United States) Language Package.

  • Go to Language Settings > Speech > Manage Voice
  • Click on Add voices
  • In the search bar type "English"
  • Install the English (United States) Language Pack

If your user profile is accurate, you (like me) are not in the USA, so probably wouldn't have this installed in Windows. Installing this meant I could finally launch MSFS 2020 (and begin what I suspect will be an overnight download of updates...).

I'm pretty sure the (absurd) reason this is needed is because on first run, the game requires the user to set the Accessibility settings, and these settings are always narrated, whatever the user goes on to set the narration setting to! And this narration is - I guess, hardcoded to be - in US English! No US English voice present => crash to desktop!!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .