4

As the title says, I am getting huge FPS drop in some games.
Currently, I'm having issues in:

What's happening is, when I'm not moving my mouse, that the FPS is super consistent (280~300 in Apex Legends, 150~160 in Marauders, 140~150 in 7DtD). But when I move my mouse... it goes crazy. In Apex, it goes almost below 40, in Marauders below 60, and in 7DtD below 20 even though I'm just wondering in forest(when it's horde, it can go below 10).

Weird thing is, if I hold LMB or RMB, the game does not stutter. So it's not completely unplayable, it just forces me to ADS or shoot the weapons (so fighting is not so much of a problem for me, only looting is).
By the way, using the controller doesn't seems to trigger the issue. I can play the games fine with it, so I think PC specs are irrelevant.

Of course I researched what could be the reason, and I found a fellow friend that's experiencing the same thing (at least in Apex): Apex stutter lags when I move my mouse(reddit post).

I am having almost the exact same issue as the on mentioned in this post, and there people suggest lowering the mouse's polling rate to 500 or 250. I was on 1000 so I tried it. That seemed to fix the issue, but it was only temporal - the issue rose again after around 30 minutes.

I'm still searching for a fix, but every post that's having the same issue seems to be fixed by dropping their polling rate. Good for them, but it's not working for me.

I suspected that the culprit was Google Play Games, since the problem just happened right after I'd installed it. So I uninstalled it, and disabled Hyper-V (because Google Play Games needed it), but the issue still consists. I thought there might be some leftover files, so I've gone and completely wiped... formatted my C drive and re-installed Windows. It seems to have fixed the issue. Oh wait, no, it hasn't - the problem rose again in 1 hour.

At this point I'm completely lost. I seem to be stuck here, since even wiping the drive is not fixing the issue.

My PC's specs are:

  • Windows 11 Professional
  • Intel Core i7 12700KF (is not overclocked)
  • nVidia RTX 3070 (more specifically, MSI's Gaming X Trio. Using the newest driver as of today, so 531.79)
  • 32GB of DDR5-5200, made by crucial
  • three M.2 drive (one 500GB drive for OS and some applications like browser, steam, etc(Crucial P2), two 2TB drive for data and games(both Solidigm P41Plus))

Gears:

  • Steelseries Apex Pro TKL 2023
  • Steelseries Apex Pro (to test if TKL 2023 is causing the issue; no changes)
  • Steelseries Apex M750 (same as above; no changes)
  • Steelseries Prime+
  • Steelseries Sensei Ten (to test if Prime+ is causing the issue; no changes)
  • Steelseries Sensei 310 (same as above; no changes)
  • and some other keyboards and mices that I don't know the name and manufacturer; no changes
  • Xbox One's controller (usually not plugged in, just checked if the problem would occur with it)
  • ASUS PG259QN (360hz monitor)
  • BenQ Zowie XL2430T (144hz monitor, to test if PG259QN is causing the issue; no changes)

I don't use any software while playing games besides Discord (to talk with my friends) and nVidia's Share (to record the game and see FPS), and sometimes a web browser (Vivaldi).
Yes, I have tried it without them running (except nVidia's Share, as I needed to check the raw FPS value), but it didn't change the situation.

Everything on my computer is up to date including my Motherboard's (MSI MPG Z690 Force Wifi) BIOS.

Any suggestions and answers are welcome (of course, that is as long as it's not "set your polling rate to 500 or below", "re-install your OS or game or anything", or "update/upgrade your PC").

If you need more info, I'll provide it.


To answer @Vilx-'s question (changing settings such as fullscreen/windowed and such would fix or do anything to the problem?) :
Sadly, no. I've tried exclusive fullscreen and borderless/windowed in every game, but no changes. I've also changed graphics settings (texture, shadow, effect detail, v-sync, etc etc...), but no avail. Changing settings from nVidia's control panel also wouldn't do anything. Capping framerate to 300, 240, 144, 120, or even 60, didn't fix the problem.

18
  • 1
    (asked question in here as per this chat post, but I am open to migrate to superuser.)
    – Skye-AT
    May 12, 2023 at 2:48
  • 1
    @Joachim Thank you. Yeah, this problem only occurs when I'm playing these two games. Other games or applications that would overload my computer is not affected to the issue, as of now.
    – Skye-AT
    May 12, 2023 at 8:41
  • 1
    @Nolonar That's included in "some other keyboards and mices that I don't know the name and manufacturer; no changes". I guess my wording was bad.
    – Skye-AT
    May 12, 2023 at 21:51
  • 1
    @TimmyJim I think I still have my 1080. I'll test with it when I get back home!
    – Skye-AT
    May 17, 2023 at 0:40
  • 1
    Here's one more idea: it sounds like something's starting to use a helluva lot of CPU when you move your mouse. Probably a different process than your game. So if you could have, like, the Task Manager open on a second monitor, you could catch it. If you don't have a second monitor, try running the game in windowed mode and hold the Task Manager opened next to it. Use the "Details" tab (it shows more info) and sort by CPU usage. Heck, maybe this even happens when you're not running a game, and it's just less noticeable.
    – Vilx-
    May 17, 2023 at 8:24

1 Answer 1

4

So, I have done testing with my old 1080 as suggested by Timmy Jim... sadly and shockingly, it didn't change the situation. However, other suggestion made by Vilx- to turn off the nVidia's share - have fixed the problem.

That have led my problem to solution. I've sought what was causing the issue. Apparently, nVidia Share's temporary file's location was the cause of the issue.

Changing the location to other drive than %localappdata%\Temp have fixed the problem. I don't know why it caused the issue, but at least my drive was not broken, since SMART says it's at 98% health.
No further investigation is planned, since problem itself is no more...


Edit:

Apparently, the actual cause of problem was not Share (though it made problem better), it was DisplayFusion.

I've encountered this problem again in The Finals, it driven me crazy and researched what was causing the issue. Luckily, this time it was easy to find it - I just googled once, "The Finals stuttering issue" or something, and the result was this Reddit post:

DisplayFusion running in the background does kill your games performance, I spent an hour last night researching what the hell was causing my game to stutter like crazy as I have the most up to date drivers and a decently beefy PC (4070ti with ryzen 9 5900x).

On a lark I decided to close DisplayFusion and start the game. That's what did the trick, I'm getting consistent 50-70FPS at 3440x1440 with every setting maxed all the way out, regardless if I'm moving the mouse or not--only as long as DisplayFusion isn't running.

Since I didn't want to kill the process of DisplayFusion every time I play games (it's really convenient app...), I've sought way, and found this comment on Reddit:

DisplayFusion staffer here! We'd like to solve this for a future update if we can. On the DisplayFusion Settings > Compatibility tab, if you add a rule for FO76 and in the rule, enable the "Disable application hooks" option, does that make any difference?

The fix was for Fallout 76, but I thought it should work on other games, and yes it did. I've made rule for The Finals, Apex, and some other games that I've encountered the problem... every game was working flawlessly. Problem solved.

2
  • Wow, really glad to see you solved this - twice!
    – Timmy Jim
    Feb 15 at 7:10
  • @TimmyJim Thanks! Actually, I think the reason I was able to solve my problem last time was not because I changed my Share settings, but maybe because Apex (and other games) were put on the block list (of DisplayFusion) at just the right time (since it was mentioned that such things exists). Good (or bad?) timing, I guess.
    – Skye-AT
    Feb 15 at 8:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .