I'm trying to run the Lord of the Rings - Battle for Middle Earth "All in One Launcher" on Linux via Wine 8.11. When I run it, I get the following error prompt:

PatchLauncherBFME.exe You must install .NET Desktop Runtime to run this application. Architecture: x64 App host version: 6.0.16 Would you like to download it now? Learn about runtime installation: https://aka.ms/dotnet/app-launch-failed

When I run dotnet --list-sdks on my Arch Linux host, it says I have both 7.0.7 and 6.0.19 installed.

I've tried installing dotnet6 and dotnetdesktop6 (it installed version 6.0.16) via Winetricks, as well the Windows versions (both x86 and x64) of .NET Desktop Runtime 6.0.19 from https://dotnet.microsoft.com/en-us/download/dotnet/6.0 then running them with Wine, but the same issue occurs.

How can I get past this issue?

2 Answers 2


You need both .NET Desktop Runtime, and hostfxr.dll

These steps result in a stackoverflow error on the particular BFME Launcher, but they get past the initial .NET Desktop Runtime screen:

  • winetricks dotnetdesktop6
  • Go to https://dotnet.microsoft.com/en-us/download/dotnet/6.0
  • Download the Windows "Hosting Bundle" (under ASP.NET Core Runtime)
  • Run it with Wine (you will now have hostfxr.dll, but it won't be in your path)
  • Go back to the folder with PatchLauncherBFME.exe
  • Run DOTNET_ROOT="~/.wine/drive_c/Program Files/dotnet/host/fxr/6.0.19/hostfxr.dll" wine PatchLauncherBFME.exe

In the last command, I have version 6.0.19 installed, but use whatever you got in the download link


Another answer is to just use wine-ge-proton rather than regular wine. It doesn't have this issue and gets past the stackoverflow error on the 2.22 Launcher.

One of the easiest ways to get wine-ge-proton is to install it as a Runner in the Preferences of Bottles, but it can also be found in the GloriousEggroll's repository: https://github.com/GloriousEggroll/wine-ge-custom

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .