2

I already asked this question on Stack Overflow, but someone told me to ask it here. So Garry's Mod is not working because some libraries were not found.

OS: Linux Mint 21.1 Kernel: 6.2.0

I apparently meet all the recommended specs for playing Garry's Mod, so it's likely not hardware-related, especially because it works perfectly fine on Windows.

I tried starting the game on Steam, but it loaded for 1 second, and the window just crashed with no error message.

What I did is running it in the terminal, at ~/.steam/steam/steamapps/common/GarrysMod I ran ./hl2_linux which told me that a library is not working.

Error: ./hl2_linux: error while loading shared libraries: libtcmalloc_minimal.so.4: cannot open shared object file: No such file or directory

What I tried (1):

So I did find / -name path/to/library and put export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:path/to/library into ~/.bashrc and did ./hl2_linux again, and another library was missing, repeat. But after doing that like 8 times, nano ended up breaking and the game just got a segmentation fault so I deleted that line in .bashrc.

What I tried (2):

A couple of things, deleting the Garry's Mod folder, deleting Proton, deleting Sniper, none of these worked.

I'll appreciate any help.

3
  • Don't have Mint to play along unfortunately, but rather than global fixes try app-specific: e.g. using launch options. This should help keep the fixes from screwing up e.g. nano.
    – l3l_aze
    Commented Aug 26, 2023 at 18:32
  • Idk if verifying game files would help? If it's a game file that should help, but I am guessing this is an OS specific file.
    – Timmy Jim
    Commented Aug 26, 2023 at 19:05
  • Guess what, I first thought the problem WAS Proton but it wasn't even enabled on GMod, so I enabled it, and it works.
    – Push
    Commented Aug 27, 2023 at 18:31

1 Answer 1

1

It's looking for the "TCMalloc" library. You're in luck: Linux Mint has that library in its repository, so you don't need to go through the pain of dealing with TCMalloc's build system.

Open up your package manager (I think Mint uses Synaptic), and install the "libtcmalloc-minimal4" package.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .