2

I'm trying to run Civilization 6 under Wine on MacOS, Intel hardware.

I've installed Heroic launcher and am using Wine Crossover 22.1.1.

The game starts, but then I cannot click "Continue" button on the initial agreement, neither with mouse nor with keyboard.

I know that mouse input kinda works because I can interrupt the intro video with a mouse click.

Is it display resolution?

I've read somewhere that the problem may be that the screen resolution that mouse perceives is different from what is rendered, and so all UI is virtually off. I tried to fix the resolution.

The original resolution in AppOptions.txt was 1792x1120. Here's what I saw in the startup logs:

0024:fixme:win:RegisterPowerSettingNotification (0000000000010046,{02731015-4510-4526-99e6-e5a17ebd1aea},0): stub
info:  Setting timer interval to 1000 us
info:  Presenter: Actual swap chain properties:
info:    Format:       VK_FORMAT_B8G8R8A8_UNORM
info:    Present mode: VK_PRESENT_MODE_IMMEDIATE_KHR
info:    Buffer size:  1792x1120
info:    Image count:  2
info:    Exclusive FS: 1
[mvk-info] Created 2 swapchain images with initial size (1792, 1120) and contents scale 1.0 for screen Built-in Retina Display.

I've tried:

  • editing AppOptions.txt, changing RenderWidth and RenderHeight to the display's resolution (3072 and 1920). The UI size has changed, but button still doesn't react to clicks;
  • Changing FullScreen to 2 and 0;
  • Enabling EnableArbitraryWindowSizing;
  • Changing DPI to 192 and to 226 (MacBook screen's native) in WineConfig.

Other ideas

Wayland (MoltenVK?) patch

This topic on Reddit describes very similar problem on Linux. They fixed it by applying some patch from https://github.com/Kron4ek/Wine-Builds, but to my understanding, this is Wayland specific. I believe MacOS needs a completely different implementation, and it's hard to track it from there to the actual code that fixes the problem.

Corrupted configs

In this Steam thread, similar problem was solved by deleting everything in AppData/Firaxis. Didn't help me.

DPI scaling

In this Steam thread, changing DPI scaling worked for someone. I may need to try other DPIs, but the most likely ones didn't help.

What else can it be?

P.S. I know that a native MacOS version exists. I already own Civ6 on iOS and would like to try it on computer, it's not worth buying another copy.

1
  • I am having the same problem, just tired of trying a thousand things and no luck.
    – Rubens M
    Commented May 16 at 0:08

0

You must log in to answer this question.

Browse other questions tagged .