27

I used to run Steam on an external drive mapped as the I: drive, and then I got a new computer and transferred my games to a secondary internal drive mapped as the D: drive. The external drive no longer works and has been disconnected.

I'm trying to play Call of Duty: Black Ops (1) that was successfully moved to the D: drive (and worked after the I: drive malfunctioned) but Steam is insisting on referencing the I: drive. When I check to see what folder Steam is getting the game from, it shows the D: drive, but when I try run the game it fails because it can't find the game's executable on the I: drive:

Error message

Failure
An error occurred while updating Call of Duty: Black Ops - Multiplayer (disk write error) : i:\steam\steam\steamapps\common\call of duty black ops

If I verify the integrity of the game folder, it comes back as no file issues, and when I go onto the Storage Manager, there's the game's .exe, clear as day, in the frikken D: drive, yet this useless garbage will keep trying the I: drive.
I can't reconnect the I: drive, due to it no longer working, and therefore cannot move anything from there to the D: drive. If I try run the executable from the D: drive directly, literally nothing happens (nothing in the Task Manager pops up for even a moment, no error messages, nothing).

All I want to do now is just point Steam to the correct location—however, I cannot find a way to do that without having to plug in the broken external drive.
How can I go about correcting this issue?

4
  • 4
    Did you move the game using Steam own "move the game" function, or did you just copy game folder to a new location? Commented Oct 9, 2023 at 6:02
  • If all else fails, using Disk Management (diskmgmt.msc) or the command-line tool diskpart to change the drive letter to I is a last resort option.
    – gparyani
    Commented Oct 9, 2023 at 6:43
  • 3
    You can also "subst i: d:\" to mirror D over to I. This is temporary though and will reset on reboot.
    – Rup
    Commented Oct 9, 2023 at 8:20
  • 1
    I'd look in your d:\steam\steamapps folder at the appmanifest_*.acf files there and see if the call of duty one has the wrong path in it. You could also try searching all of your files in your steam folder for I:\ - you'll need a separate utility I think, e.g. grep - or search the registry for I:\. It must be getting it from somewhere.
    – Rup
    Commented Oct 9, 2023 at 8:27

1 Answer 1

38

Uninstall/Reinstall the game

I initially assumed this would fail, given that Steam was referencing the (non-existent) I: drive, but it uninstalled instantly. Upon reinstalling, Steam asked which drive to use, and since nothing changed in the D: drive, the reinstall detected the existing files and finished within a few seconds, and now it works.

1
  • 9
    As this solves your issue and re-installing the game is a valid approach I suggest you accept your answer to your own question, which you can do by clicking the grey outlined check-mark on the left under the vote count :)
    – whme
    Commented Oct 9, 2023 at 6:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .