0

I have a problem with a freshly installed Killing Floor 2 on my laptop (Steam version). Upon launching the game, it shows a black screen instead of the main menu. I can hear the main menu music in the background, so I think the game is running but not displaying properly. My laptop has a GeForce MX150 GPU and runs on Windows 10. How do I fix this issue?

1 Answer 1

0

In my case, I found out that it was caused by the default values in my KFEngine.ini file for Min/MaxAllowableResolutionX/Y being set to 0. To fix this, I followed these steps:

I made a backup of the KFEngine.ini file (in case I need to restore it in the future), which is located in this directory:

%USERPROFILE%\Documents\My Games\KillingFloor2\KFGame\Config\

Then, I opened KFEngine.ini using a text editor and replaced the [WinDrv.WindowsClient] section with this:

[WinDrv.WindowsClient]
AudioDeviceClass=XAudio2.XAudio2Device
MinAllowableResolutionX=768
MinAllowableResolutionY=768
MaxAllowableResolutionX=1366
MaxAllowableResolutionY=1366
MinAllowableRefreshRate=30
MaxAllowableRefreshRate=240
ParanoidDeviceLostChecking=1
AllowJoystickInput=1

I changed the values of Min/MaxAllowableResolutionX/Y (previously 0) to match my monitor's native resolution (1366 × 768). For example, if your monitor has a resolution of 1920 × 1080, you should use these values:

MinAllowableResolutionX=1080
MinAllowableResolutionY=1080
MaxAllowableResolutionX=1920
MaxAllowableResolutionY=1920

I saved the file and restarted the game. The black screen issue should now be gone.

I got the idea to fix it this way from this Reddit comment: "Killing Floor 2 Stuck at low resolution bug", where someone used it to fix a different bug related to low resolution. It seems that both bugs are caused by the same issue with the KFEngine.ini file.


If the issue persists, here are some other things you could try.

Try toggling between fullscreen and windowed mode.

To do this, open the KFSystemSettings.ini file (but back it up first), which is located in this directory:

%USERPROFILE%\Documents\My Games\KillingFloor2\KFGame\Config\

Look for the text Fullscreen= under [SystemSettings] and toggle it to be True (fullscreen) or False (windowed), e.g., Fullscreen=True if initially false and vice versa. Note that there are many variables named Fullscreen in KFSystemSettings.ini. You need to edit the one under the [SystemSettings] section. In my case, it's line 36, the first instance that appears in the file.

If the above works but it's in windowed mode, try toggling the Borderless= setting in KFSystemSettings.ini.

Search for the text Borderless=, located under [SystemSettings], and then set it to be Borderless=True. This should set it to borderless windowed mode.

5
  • Unfortunately this did not work for me. I followed these instruction exactly and still just get a balck screen with music.
    – Robert
    Commented Oct 20, 2023 at 12:07
  • @Robert To investigate this further, what were the Min/MaxAllowableResolutionX/Y values prior to you editing it? Commented Oct 20, 2023 at 12:15
  • They were all 0. I use a 1920x1080 resolution so I used those values but still got a black menu. However, I have managed to play since then, one of these changes must've made a difference: 1) I reinstalled the game 2) I disconnected my VPN 3) I started the game with the -windowed flag. One of those three must've worked because the game started normally
    – Robert
    Commented Oct 22, 2023 at 16:38
  • @Robert Thanks for mentioning that. I think it's number 3. I've added this information to my answer. Are you still playing in windowed mode? Because you can set it to borderless windowed mode. Commented Oct 23, 2023 at 4:57
  • Yes, but only for starting up. I still have issues where the screen is black sometimes but at least in windowed mode I can kill the game with the task manager. Once I see the game loads the main menu properly I can alt+enter to get fullscreen
    – Robert
    Commented Oct 24, 2023 at 13:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .