2

So this has been an issue for a while now. Last few updates were greeting me with that error message after about half an hour of waiting every time I opened the launcher.

Last time I searched the web I found a page I can't find anymore suggesting to uninstall and use the Legacy launcher and that worked for the base game* However this time around when I did a fresh install it's giving me the error and I can't install the game at all.

I tried the main AND the legacy launchers, I tried clearing every single file on my computer related to Minecraft thinking maybe something's corrupted, I tried punching a hole through my desk to relieve the unbridled anger this whole thing sparks within me.

No success, the desk is still in one piece and the game is still unplayable.

I can't seem to find any resources that apply to it. Most articles I've seen brings up Windows 11, I'm on win 10 and can't update to 11 because Microsoft decided my computer hardware isn't compatible. If it's not win 11 related it's a different error altogether.

I just want to be able to play the game I spend my own hard earned money on, but instead I'm getting frustrated just trying to update the stupid launcher.

Can somebody help me out? Please?

*using curseforge for modpacks would still give me the error after a long wait on previous versions, now that I've uninstalled the game and can't get it to run curseforge obviously doesn't pick it up on the system

0

1 Answer 1

1

Welcome to Arqade! On Google, I found this: helpdeskgeek
It lists some potential methods to fix your problem, but I'm excluding a few because you've already done it, or what you have done rules it out. So, what remains is:

  1. Launching it as an administrator
  2. Run the program compatibility troubleshooter
  3. Temporarily disable your antivirus
  4. Download Minecraft w/o the launcher. 

Launching as an administrator
Now I'm sure you probably already did this or know how to. But just in case, you can try launching it as an administrator by right-clicking on the application, clicking "Run as administrator" and then clicking "Yes" when it asks you to allow it to make changes to your device.

Run the program compatibility troubleshooter.
Windows provides a troubleshooter for games not downloaded from the Microsoft store. You can access it and run it by right-clicking on the app icon, then click "Open file location", right-clicking on the game's icon in the files, then clicking "Troubleshoot compatibility" and following what it says.

Temporarily disabling your antivirus
Sometimes antiviruses get in the way of downloading stuff. Look up how to disable the antivirus that you use and then try it again if you haven't. ONLY DO THIS IF YOU KNOW THE THING YOU ARE DOWNLOADING IS SAFE

Download Minecraft w/o the launcher.
I have never tried this or know how it works, but Minecraft does have an alternative download page here that downloads Minecraft without the launcher. Follow whatever it tells you to do, and it may work.

I hope this helps resolve your issue, if it doesn't, please tell me and I will try to help in any other way I can.

1
  • I found out what the issue was after a bunch of troubleshooting. Apparently the update/s break when I use a VPN. Thank you for your help, it led me to try a few things that had slipped my mind (namely trying to launch as admin) A little heads up though, the link you provided for an alternative download does still download the launcher, I couldn't find a tangible difference between the main download and the one you provided other than the webpage it's located on. Hopefully I remember this next time the darn thing breaks. Commented Oct 22, 2023 at 20:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .