I am following this guide to become Thane of all the holds in Skyrim. The Jarl Siddgeir does not ask me for a drink, I completed Dengeir's quests. I completed the all the quests Dengeir gave me plus most of the quests for the people of Falkreath. I do not have any more dialogue options from either the Jarl or Dengeir. Is this bugged?

I have not completed much of the main story line quests or the civil war quests. Is it possible to become Thane of all the holds without completing the main quests or the civil war quests?

  • Hm. I haven't done any of the civil war quests and Siddgeir asked for a mead the first time I asked him for work. So it's definitely possible. Commented Dec 8, 2011 at 4:42

4 Answers 4


Windhelm requires you resolve the civil war one way or the other before becoming Thane or purchasing the house. Whiterun requires you complete the first couple of quests in the main quest chain. Falkreath has no such restrictions.

However, the first quest you have to do for the Jarl can be blocked if you have another variant of the Rare Gifts quest under the Miscellaneous section in your journal. If you do, complete it. If you don't, visit all the other possible quest givers, and if any of them offer you the quest, complete it, then check back with Siddgeir again. Repeat if necessary.

  • @desaivv It's also worth noting that you can often (maybe always?) buy Black-Briar Mead right at the inn in Falkreath, if you happen to get the quest while not carrying any. Since you know you're going to need it though, I'd just stop by the meadery and get some if I were you.
    – agf
    Commented Dec 8, 2011 at 6:16
  • @desaivv That won't affect anything. He's one of the kills where you can just talk to him and he'll attack you so when you kill him it's not even a crime.
    – agf
    Commented Dec 10, 2011 at 6:55
  • As per Knifepoint Ridge: Bugs, there can be another issue with becoming Thane in Falkreath. Commented Aug 21, 2015 at 21:39

I've been playing with console commands to try and get a fix to a hearthfire bug, and I think I may have figured out this problem. You can only have one Favor110 quest active at a time. Follow the above link. If you have any of the other Favor110 quests active, he will not speak with you. Make sure to complete (or skip) any of the other Rare Gifts quests and he will be available to give you quests to make you Thane.


As for problems completing 3 quests to become Thane of Falkreath, it's not glitched, at least not completely. If you are like me, you are working on this later in the game and many of the people in the town have been killed off by one or more dragons that you've had to fight over Falkreath. So many of the suggestions people are giving don't work. The Farmer and his wife are dead or gone, same with the blacksmith and others. The "dropping stuff in front of the soldiers" trick doesn't work. I found that I had 2 of 3 quests completed to help citizens of Falkreath, and couldn't find a third to finish it off. It seemed I was at an impass. The quest to rescue Valdr (Hunter and Hunted) you get from Valga Vinicia, the tavern keeper of Dead Man's Drink, doesn't count for some strange reason. Neither do one or two others. I was about to give up and call it an unresolvable bug... then I realized that the citizens you need to help don't have to be in the town of Falkreath - they need to be within the larger region of Falkreath Hold. I eventually found Heri at Half-Moon Mill on the west side of Lake Ilinalta (NW of Falkreath) and chopped some wood for her. Voila, third quest finally completed! I am now Thane of Falkreath, but Jarl Siddgeir is a poohead. And no, you do not get the option to buy a house in Falkreath.


Well, the above message point out to find someone else in the Falkreath region and not necessarly in the town worked for me on the Xbox.

I had done two in town favors, then tried resolving werewolf guy, uncle vampire (bloodlet throne,) and the dedra dog's grand tour of over Skyrim None of these three resolved for third favor. So, I went to the mill, chopped some would, and that simply made #3. (bing your own ax, theres none laying about.)

I really don't try to read these things until I just get really stuck; this game is fun though.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .