I had a Minecraft server on my main PC, and decided to move it to my laptop. When I started it, my friends could join with my public IP address, but I can't join with the IPv4 IP nor the public IP. I tried disabling Windows Defender on both devices, but I still couldn't join.
The server is connected to the same router I'm using on my main PC, so I'm wondering why I can't join.
I also tried allowing port 25565 in Windows Defender, but it still didn't work.

  • Did you point your IP forwarding to your laptop?
    – aytimothy
    Commented Mar 23 at 12:54
  • Yup I did Im sure I did it right since when I go to portchecker.co it says port open when the servers running Commented Mar 24 at 12:13
  • What IP are you using to connect (should be 10.x.x.x or 192.168.x.x)? Run ipconfig on your server computer and client computer and look for an address like the one I posted. Use the address on your server computer to connect on your client. Also, what router are you using? | It is very unlikely for that IP to be or (those are usually reserved for the router/modem itself)
    – aytimothy
    Commented Mar 25 at 2:08
  • I am using pldt fibr f670L and i used the ip in ipconfig still doesnt work Commented Mar 25 at 2:42
  • Your router (as configured by your ISP) is likely preventing connection via LAN, i.e., you won't be able to connect to any other device connected to that router—your laptop in this case. There's not much you can do about it unless you contact your ISP and ask them to enable this functionality (or how to enable it). Commented Mar 25 at 4:15

1 Answer 1


This may be due to mods or version incompatibility. If you can't join even with no mods and have the correct version of minecraft installed, you may be missing mods the server has. But if you still can't join, I recommend uninstalling and reinstalling Minecraft entirely, or use the windows+R keys to access %appdata%, check for any unwanted files (example: badlion client), scroll through and find anything you don't want and delete it. while in .minecraft folder check the mods folder and resourcepacks folder, as well as the sever-resource-packs folder.

These can be accessed in the search bar by typing it like this: .minecraft/mods, .minecraft/resourcepacks, .minecraft/server-resource-packs without using quotation marks.You can find mods inside the mods folder and move them to another folder which I recommend creating a new folder called "Mods Removal" in order to keep track of where your unsed mods are.

I also recommend doing the same for resource packs and shaders, as having any shaders or resource packs added in these active folders can also cause some issues for different minecraft versions, such as lag and the game closing due to error.

I've personally experienced a lot of lag and errors and found my own work arounds to solving these issues. If you still experience issues I recommend uninstalling and reinstalling. You won't be charged for it. But if you still can't join, it's possible you were banned from your own server somehow. It is possible but it can be undone by going to the servers player list and whitelisting yourself back in if you aren't whitelisted.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .