3

Every time I open Hogwarts Legacy on my PC, then I get a message that says the following:

Steam is currently in Offline Mode. For the first launch go in Online Mode. Select "Steam' in the upper left corner, "Go Online...", connect to the Internet, and follow the instructions. Afterwards restart the game.

Bottom right of the popup message, there is an "OK" button like this:

Hogwarts Legacy: Steam is currently in Offline Mode. For the first launch go in Online Mode.

When I click on the "OK" button, then the game just closes and never opens.

But the thing is, my Steam isn't in Offline Mode. It's online. I am connected to the Internet. I'm typing this question now on the same internet.

Here you can see that I am online:

Shaun Roselt Steam Account playing Hogwarts Legacy

Shaun Roselt Friends Tab on Steam

Steam menu

From the screenshots, you can clearly see that I am online and connected to the Internet on Steam.


I am always online and connected to the internet.

What's causing this? How can I launch Hogwarts Legacy?

I've already restarted my computer and this is also a clean install of Windows, Steam and Hogwarts Legacy.


The only two possible issues I can think of are that the game is just broken or perhaps it's my slow internet which also kind of ties back to the game being broken since it shouldn't matter how slow or fast my internet is.

Slow internet speedtest

But regardless, how can I fix this?

or should I just accept that this is a bug in the game and I can't play the game?


Some extra info:

I also fully updated my Windows to the latest version as well as my drivers. Here are my specs, and software versions:

  • Windows 11 Version 23H2 (OS Build 22635.3646)
  • NVidia GeForce Version 555.85
  • AMD Adrenalin Software Version 24.5.1

And my Steam System Info with Specs and everything:

Computer Information:
Manufacturer: Standard
Model: Standard
Form Factor: Laptop
No Touch Input Detected
Processor Information:
CPU Vendor: AuthenticAMD
CPU Brand: AMD Ryzen 7 8845HS w/ Radeon 780M Graphics
CPU Family: 0x19
CPU Model: 0x75
CPU Stepping: 0x2
CPU Type: 0x0
Speed: 3793 MHz
16 logical processors
8 physical processors
Hyper-threading: Supported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Supported
SSE41: Supported
SSE42: Supported
AES: Supported
AVX: Supported
AVX2: Supported
AVX512F: Supported
AVX512PF: Unsupported
AVX512ER: Unsupported
AVX512CD: Supported
AVX512VNNI: Supported
SHA: Supported
CMPXCHG16B: Supported
LAHF/SAHF: Supported
PrefetchW: Unsupported
Operating System Version:
Windows 11 (64 bit)
NTFS: Supported
Crypto Provider Codes: Supported 311 0x0 0x0 0x0
Video Card:
Driver: NVIDIA GeForce RTX 4060 Laptop GPU
DirectX Driver Name: nvldumd.dll
Driver Version: 31.0.15.5244
DirectX Driver Version: 31.0.15.5244
Driver Date: 5 7 2024
OpenGL Version: 4.6
Desktop Color Depth: 32 bits per pixel
Monitor Refresh Rate: 240 Hz
DirectX Card: NVIDIA GeForce RTX 4060 Laptop GPU
VendorID: 0x10de
DeviceID: 0x28a0
Revision: 0xa1
Number of Monitors: 4
Number of Logical Video Cards: 4
No SLI or Crossfire Detected
Primary Display Resolution: 3840 x 2160
Desktop Resolution: 15360 x 2400
Primary Display Size: 23.54" x 13.23" (26.97" diag), 59.8cm x 33.6cm (68.5cm diag)
Primary Bus: PCI Express 8x
Primary VRAM: 8187 MB
Supported MSAA Modes: 2x 4x 8x
Sound card:
Audio device: Headset Earphone (CORSAIR VOID
Memory:
RAM: 64810 Mb
VR Hardware:
VR Headset: None detected
Miscellaneous:
UI Language: English
Media Type: Undetermined
Total Hard Disk Space Available: 3906567 MB
Largest Free Hard Disk Block: 475080 MB
OS Install Date: Mar 08 2024
Game Controller: Android/PC Gamepad detected
Storage:
Number of SSDs: 1
SSD sizes: 2048G
Number of HDDs: 0
Number of removable drives: 0

2 Answers 2

1

Looks like it is truly a bug in the game where you need to have a good internet connection otherwise the game thinks that you're offline.

I tried everything, but nothing worked.

In the end, I connected to a different faster internet connection and it worked. I was able to get into the game.

Internet Speed test

After I connected to this new internet, it worked without any issues.

So even though I had internet on the slower internet, it thought I didn't.


Note though. After I went into the game with the faster internet, I was able to switch back to my slower internet and continue playing without any issues.

0

That popup is not from Steam but from the game itself, and it's because of Denuvo Anti-Tamper DRM.

Denuvo Anti-Tamper ... requires an online connection periodically as the system environment ... changes with new hardware and/or Windows updates. ... described as requiring a periodic online connection every fortnight (2 weeks) or so. Players gaming offline for a long period of time can also suffer if proper preparations are not made in advance to ensure the validity of the offline token. The lack of transparency on storefronts ... means people might not be aware of its presence and periodic online requirement before purchasing a game that, after purchase, [they] may find unplayable when an online connection is unavailable.

  • Limited to five daily activations per game, which resets 24 hours after the first activation.
  • Capable of offline token renewal through a support page (e.g. Metal Gear Solid V: The Phantom Pain) if supported by the platform. Origin and Uplay titles do not support this as their token generation is handled within the platforms respective internal activation process where offline is not an option.

So, apparently Hogwarts Legacy doesn't support offline token generation.

And as it says above, there is no mention of it requiring an internet connection on the Steam store page. Only a mention that it includes Denuvo Anti-Tamper as DRM.

TLDR: It should be playable for about 2 weeks (depending on Windows updates/hardware changes/the alignment of the planets) before you need to use a more stable internet connection again long enough to login.

2
  • 1
    Yes. I know it's from the game. That's why I said it's probably a bug in the game, because I have an internet connection. I am online. But the game thinks that I'm offline. Commented Jun 2 at 8:46
  • Yeah, it was just way too much for a comment, and likely would've surpassed the edit limit.
    – l3l_aze
    Commented Jun 3 at 0:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .