17

As silly as it sounds, I just can't manage to switch out and back into full-screen games on my MacBook, like Alt-Tab does on Windows. I've tried searching online and found posts saying I should use the (Command) key with m or f or Esc, but none of these work... and in general I had some trouble searching for it online since Lion has a new "fullscreen" feature for applications which behaves differently than fullscreen games but is called the same. :(

So, is there a way to do this?

Right now I'm relying on the Steam overlay which allows me to access a browser from in-game, but sometimes I want to access other applications and I just can't figure out how.

  • Does F10 do anything when in full screen? – au revoir Dec 10 '11 at 5:34
  • @Jason nope, nothing. – Oak Dec 10 '11 at 10:00

10 Answers 10

11

tab usually is correct.

Unfortunately many games are badly ported - so they often do not support it in full-screen mode. Some games (for me Telltale games) allow to switch to a "window" mode - when you are in that it is typically possible to switch.

| improve this answer | |
  • 1
    I tried playing a few games in windowed mode while setting their resolution to be the same as the monitor's, but that always leaves the Dock and menu bar on top of the game, rather than underneath it :\ and yes I can play windowed with a smaller window, but that's a shame. – Oak Dec 9 '11 at 22:01
  • You can set the dock to autohide (putting your cursor near it un-hides) and there are utilities to hide the menu bar if that's your only option. – authenticgeek Dec 10 '11 at 0:00
  • @Nick any examples of such utilities? I've set Civilization V to a smaller window because of the menu bar. – Wilerson Dec 12 '11 at 17:59
  • 2
    @Wilerson How about MagicMenu? Most people report success. – authenticgeek Dec 12 '11 at 18:02
  • @Nick nice, it worked! – Wilerson Dec 12 '11 at 20:23
5

cmd + option + esc will always work. it's the analog to ctrl + alt + del

| improve this answer | |
  • 2
    Not entirely True. It works, but it is analog to ctrl + shirt + esc. Ctrl alt del will not give the task manager immediately, while cmd option esc will. – Mathias711 Jun 22 '15 at 16:43
  • 4
    This exits the app. Not a good solution. – jvriesem Nov 27 '17 at 4:50
4

What I end up doing is the 3 finger (upwards) swipe. Then I select something on another desktop and it pulls me over there.

Though Cmd+Tab usually works for me....

| improve this answer | |
  • 1
    That swipe doesn't work for me during a game... – Oak Dec 9 '11 at 23:46
  • Hmm...I'm not good enough with a Mac to know why it doesn't work for you, but it works for me. – the_e Dec 10 '11 at 0:35
  • @Oak What about a sideways four-finger swipe? Each fullscreen app acts like its own "desktop", and that's the default desktop-switching gesture. – SevenSidedDie Sep 1 '13 at 4:23
0

I can't command tab or anything out of the game, but rather I just close my computer lid, let it sleep. When I log in again, or wake my computer up, it shows the desktop, the game temporarily closed. Then you can do whatever you want then press the game button again and the game will open again. That's how it works for me with Skyrim and GTA.

| improve this answer | |
0

Command + Enter = Windowed Game and Command + Tab = Hiding the game

| improve this answer | |
0

Go to steam, press the steam tab at the top left. Go to preferences. Go to the in-game tab and click on the overlay shortcut keys and press f5. Restart whatever game you are playing and press f5 to tab out and there you go. Hope this helped :D

| improve this answer | |
0

IF possible, rather than play the game's built in fullscreen mode, play in windowed and then use the arrows at the top right corner on the window, the using f3(on a desktop it may be different on a laptop but it looks like three different sized windows next to each other) and selecting desktop or the game.

| improve this answer | |
0

cmd + f(fullscreen) worked for me. then you change the resolution for prefer size.

| improve this answer | |
-1

This works on the Halo trial, but I'm not sure if it works with other games. Try Command+H.

| improve this answer | |
-1

If cmd + tab doesn't work for you, try cmd + esc! That worked for me!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.