There is a quest in Windhelm where you have to find a white phial for the alchemist.

This quest is not a problem, after many days, you get a letter from him again to meet him at his shop.

Its this next part that is the problem.

He tells you he wishes to repair the phial, and needs you to collect some ingredients, Getting the Unmelting snow and powdered mammoth tusk was fairly easy, but there is a horrible glitch which has stopped me in my tracks for the third and final ingredient.

Its a Forsworn briar heart, needed to be taken off a certain person, so getting any briar heart will not suffice.

Now the person i need to get it from has been killed already earlier doing the red eagle quests, and if that weren't bad enough, he has no briar heart on his person, yet its still telling me that i must pick one off this person.

This is on the Xbox, so console commands cannot be used, Has anyone come across this also? and if so, have you got around it? does anyone have any info to help.

I have looked on the internet for solutions but there is not much to help.

EDIT: Quest works now.

This glitch seems to have been solved, a recent update must have found a way round this, the briar hearts could be eaten and then once all gone, they were not quest related, finally. and the quest could be completed too, as before he wouldnt accept your ingrediants, however now he does. thanks

  • Oh damn... I've done the Red Eagle stuff and haven't started on the White Phial quest yet...
    – Holger
    Dec 10, 2011 at 8:15
  • Can anyone else confirm this? I had done the Red Eagle quest, also, before undertaking the Repairing the White Phial quest. I had a Briar Heart in my inventory, so I dropped it on the ground and picked it back up, and the game said the objective was completed.
    – brymck
    Dec 10, 2011 at 9:42
  • 1
    How do you trigger this part of the quest? I brought him the broken phial and never received any correspondance after. It's been weeks (in game) since I completed this portion. Do I need to do something in particular to get this next part?
    – spugsley
    Dec 10, 2011 at 14:24
  • @spugsley You must have visited the Throat of the World first, due to the location of one of the ingredients. I had the same thing happen and just gave up on it, then a courier appeared out of the blue when I was (finally) doing the main quest.
    – brymck
    Dec 10, 2011 at 16:02
  • @Bryan Yeah...I haven't really done anything for the main quest though I'm leader of both the Thieves Guild and the Dark Brotherhood lol. I'll get to it eventually. Thanks!
    – spugsley
    Dec 10, 2011 at 16:12

3 Answers 3


The briar hearts in this quest are apparently prone to glitches. I found this thread where people are discussing the various ways in which they were able to break this quest. In some cases, when they got notification that they needed to get that specific briar heart, all the briar hearts they already had became quest items.

I think the best you can do is load an earlier save, or hang on to this quest until Bethesda patches it to work properly. Even so, you might not be able to finish it unless they create some way to reset your progress in it or otherwise fix the quest if it is already in progress.

  • The quest seems to be fixed in patch 1.4.15. As I am playing on computer I upgraded to the beta, the quest updated and I was able to end it. I don't know if patches applies to Xbox versions. So wait a little bit. Jan 28, 2012 at 19:22

If you can locate the specific corpse they want you to find, try placing a briar heart in the body, closing it, reopening it, and taking the heart. You can source the spare briar heart from another Foresworn, an item placed in the world, or the randomly-generated ingredients at an alchemist.

  • 1
    In my game, Briar hearts cannot be placed or dropped due to becoming quest items, i have tried your way already but without success, good thinking though. Dec 12, 2011 at 6:25
  • @monkeyman1188 Ah, that's a very good point. I believe the area should reset itself after a time, perhaps 15-20 game days. Maybe focus on a different set of quests for a while and come back to this one? Dec 12, 2011 at 6:41

A possible workaround from UESP Wiki, "Repairing the Phial - Bugs" article:

If you have initiated the quest to find Red Eagle's sword, the same Forsworn Briarheart might be the target of both quests. It will carry both Red Eagle's sword and a briar heart. However, even if you pick up both, it will only complete the Red Eagle quest. You will need to find a different Forsworn camp to complete the briar heart part of this quest.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .