I bought GTA3 on Mac App Store, and wanted to play it with my new PS3 controller on my MacBook. It works fine for playing on foot (left stick for running, right stick for view). But in car I can only use left stick for steering, and can't use analog stick for throttle.

I tried to redefine the controls on car, but when move the sticks they are not recognized in the "redefine controls" menu, only buttons are recognized.

How can I make so that I can control throttle with analog stick?

UPD. Actually I cant reassign analog sticks at all, not even change steering from left to right stick, they are simply not recognized, and I can play only on default settings for sticks.

UPD2. What about GTA SA, then? Will I be able to to control both throttle and steering with analog sticks in it?

  • I don't believe the situation is any different in the other GTA3-series games - they're all ports from the console versions of the games. If you get to change the button layout at all, that's more than what we got on consoles :(
    – agent86
    Dec 13, 2011 at 19:28
  • @agent86 "other GTA3-series games" you mean SA as well? It also didn't have analog throttle on consoles?
    – Halst
    May 11, 2013 at 17:14

2 Answers 2


The original version of GTA3 used a button, and not a analog stick axis, for both throttle and brake. On the other hand, the DualShock 2 had pressure sensitive button support, so on the PS2 they were more like analog controls than digital buttons.

However, most of the ports of GTA3 don't support analog throttle/brake for whatever reason. It might be possible to use a controller remapping program (AutoHotKey is my go-to for this, but I think Controllermate might fill a similar niche in OSX) in order to change this behavior. However, it's likely to break other things you'd want to do with the right analog stick - like looking around when you're on foot, for example.

I think in the end you might just have to chalk this up to a missing feature in the ports of GTA games.


Yes if you have the ps3 controller connected go to options in the game, then go to controls, then go to reconfigure controls and set it up how you want.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .