5

I have bought a number of spells in the alley but they are not working or available to access. When I rotate the spell wheel around I see the pink option and sometimes if I am lucky I get the frog option but only if I go back to the shop and stand on the square to select the frog spell I already bought, but that's it.

There's no change of purchased hexes in the pink area of the wheel when I am in the alley, though it changed automatically in LEGO Harry Potter Years 1-4. I am still on year 5 but I have done a few areas of it and have access to a number of earned spells including the red spell that allows you to open red objects.

Does anyone know how I access my many purchased spells (not the earned ones from the game) that I have bought in LEGO Harry Potter Years 5-7?

3 Answers 3

3

Access to the "fun" spells has changed in LEGO Harry Potter: Years 5-7. In the previous game, all the purchased spells occupied a single entry on the spell wheel and constantly cycled without input from the player. Casting a specific spell required you to target a person and wait for the spell to appear in the spell wheel before casting.

In this game, all the purchased spells still occupy a single entry on the spell wheel, but you are in control of which one you want to cast. You did not mention what platform you are playing the game on, but on the PS3, pressing and holding the triangle button will bring up an on screen spell wheel. While the spell wheel is on screen, the purchased spells automatically cycle, just like in the first game, but when you release the button, the spell that was displayed becomes the active spell.

Your choice then remains selected as you play, so that you can cast that specific spell on the other characters in the game.

5
  • Thanks for the replies. James I am using a PC. Do you know which button I need to use on the keyboard to cycle through when I am on purple spells? I have tried loads and loads of buttons but clearly not the correct one.
    – OB1
    Commented Dec 14, 2011 at 19:43
  • Unfortunately, I don't. It likely will be one of the keys you already use for other purposes, since the game will be similar to the console versions. The triangle button on the PS3 is used for switching characters and for boarding vehicles, when it is pressed once. However, if you press and hold it down, it brings up the spell wheel.
    – au revoir
    Commented Dec 14, 2011 at 20:18
  • Ahhh, thank you, that is the letter U on the PC. I will try holding it down.
    – OB1
    Commented Dec 14, 2011 at 20:37
  • I just held down U in the alley when on pink and it works perfectly - thank you!!!!!! Problem solved.
    – OB1
    Commented Dec 14, 2011 at 20:45
  • No problem. Feel free to mark this as the accepted answer - there is a checkmark you can click just under the number of votes the answer has received (on the left hand side).
    – au revoir
    Commented Dec 14, 2011 at 21:06
1

Are you trying to access the spells in free play or story mode?

I haven't bought any spells yet or started free play, but I wouldn't be surprised if you could only access the additional spells in free play mode (just like how you can only access any additional characters you've bought in free play).

-1

If you want to access the spell wheel in Lego Harry Potter, you have to press and hold the green triangle button.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .