Since I received the Dashboard Preview I have been unable to join Xbox Live parties and nobody can join mine. I'm not 100% sure this coincided with the Preview program, but I think it was around the same time so I'm assuming that's what is causing it. Obviously, all my friends are now on the new dashboard, but I'm still a member of the preview program (have a "pre-release" tab).

My router is configured so that my Xbox is the DMZ based on MAC, so it shouldn't be a port forwarding issue.

If nobody has any direct solutions, I'd at least like to know how to leave the preview program to see if that helps...


  • Have you tried resetting your xbox?
    – Nick122
    Dec 20, 2011 at 12:48
  • lol... this has been a problem since late November. Dec 20, 2011 at 12:54
  • Just checking. But good question.
    – Nick122
    Dec 20, 2011 at 12:55
  • 1
    This just started happening this week for me.
    – Yatrix
    Dec 20, 2011 at 13:18
  • 1
    Have you tried testing without the router?
    – Allov
    Mar 19, 2012 at 21:18

2 Answers 2


I'm also in the dashboard preview. I've had a similar issue since early November, but I don't know if it's exactly the same. It comes and goes.

  • I can send messages to other people, (party and game invites, for instance) and they get them, but trying to respond to them just times out.
  • If other people send messages to me, I can't receive them. If I log out and log back into Xbox Live from the Xbox menu, then I'll get a flood of messages all at once.

If I manage to get one of these messages, and the lobby or party is still open, I can join the lobby/party. Usually when I've identified that this is the problem, I'll ask my friends to start a lobby and send me a combo party/game invite, and then I'll quickly log out and back in, and accept the invite.

Sometimes this happens in reverse (ie, I'm the one who can get messages that I can't respond to), and the workaround is reversed. It requires a decent amount of patience when this happens in order to get to play with my friends.

If this isn't your issue, or it doesn't solve it, you'll want to talk to Microsoft via the Connect Dashboard. You should have access to this page if you're in the dashboard preview. From previous experience, I don't think they're able to roll back your dashboard revision, but you might find a solution or workaround, and at the very least, we're helping everyone else avoid this issue when the update goes live.


I switched from AT&T DSL to AT&T Uverse. With the new 2wire modem/router everything works flawlessly. I still think this is some sort of compatibility issue with the dashboard update and certain routers, but I suppose we'll never convince MS of that.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .