So went to Markarth to do the forsworn conspiracy and I got to the first part got everyone's diaries and talked to a bunch of people about Weylin and Margaret. When I go back to see Eltry hes already dead and the guards are just standing there and wont say anything.

I also returned back to the warrens to talk to Dryston in Weylin's room there's the arrow above his head but he doesn't say anything when I try to talk to him. Anyone know how to fix this?

  • Could you take a screenshot of the journal page for the quest line? You don't mention anything about talking to Nepos or the treasurer (I forget his name).
    – bwarner
    Dec 20 '11 at 17:38
  • Oh your right, my bad. I went to Nespos house and went to talk to him and then him and everyone started attacking me and I killed him so I probably wont be able to finish the quest >.<
    – Dani
    Dec 20 '11 at 18:13
  • You're supposed to kill the Nose, that's what my understanding is once you discover who he is.
    – Jakub
    Dec 20 '11 at 18:18
  • 1
    @Dani No, that's supposed to happen. Did you grab and read his journal?
    – bwarner
    Dec 20 '11 at 18:19
  • Ya, I have his Journal
    – Dani
    Dec 20 '11 at 18:22

It looks like you're suffering a bug.

According to uesp

If the Markarth Guards do not warn you off after having investigated the Inn for Eltrys and you get stuck (Guards won't arrest you) when returning to him after finding out all you can about the Conspiracy, if you wander the streets and do meet the Guard who warns you off and then returning to the Temple, you will still get arrested (or attempted to get arrested).

So it looks like you need to talk to all the guards in the city.

Another possibility is this (I hope this isn't your problem - no way out):

If you enter The Warrens before your first talk to Eltrys in Shrine of Talos, a Nord named Dryston will approach you. He will tell you that "it's time you learned a lesson" and brawl with you. Once you beat him, he will NOT tell you that "N" is Nepos the Nose as you did not get this quest yet, this will lead to a BUG where you can not complete this quest 'find out who "N" is' once you read Weylin's Note (if you read it right after you find it by lock picking the Weylin's door, it will not start the quest, as you did not speak to Eltrys yet).

  • 1
    Thanks :) I think I actually wont be able to finish it but thanks for the help :)
    – Dani
    Dec 20 '11 at 18:16
  • 1
    It's a very fragile quest line. When I ran it, I paid inexplicable bounties twice and the Shrine of Talos is now permanently under guard by malfunctioning troops.
    – Amy B
    Dec 20 '11 at 19:39

I know this question is old. But I had the same problem today and managed to fix it.

There are supposed to be three guards in the temple. If there are just two of the, the one who triggers the quest is missing.

If this happens just leave Markarth (I quick-traveled to Whiterun) and wait for three in-game days. This resets Markarth and the temple. Now the missing guard should be there and trigger the quest correctly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.