I've noticed this mainly when waiting for several hours through the night. I always make sure that it's around 10-11am, or at least 9, so the shops in particular (perhaps not the houses) should be open. But on occasion they just stay closed and locked and I'm wondering if there's anything I can do to prevent this.

I know some shopkeepers walk to their shop so it's not always immediately open in the morning, but I've waited around for several real-time minutes with no result.

If I wait until after opening times, shouldn't the shops already be open?

  • Can you give some specific examples of shops that are still locked even after you wait several RL minutes for the owners to walk over and open them?
    – agf
    Dec 22, 2011 at 1:03
  • @agf I was waiting patiently for Calixto's House of Curiosities, running around for a good 5-10 (real) minutes in broad daylight. Maybe the NPC took an impromptu holiday?
    – Alex
    Dec 22, 2011 at 13:39
  • You were waiting at Calixtio's? you were probally going to look at the museum or give the Amulet from Blood on the Ice to him right?
    – Jim
    Oct 11, 2015 at 18:44

8 Answers 8


You mention above that you were waiting at Calixto's - I had the same issue multiple times.

Then I discovered a particular Windhelm quest - turns out the shop owner is occasionally "out" doing other things because of the related series of events. Once you start the quest line, this also limits the shop's hours of operation. I won't spoil you with the name of the quest, but I'd recommend just shopping elsewhere.

  • +1 interesting, I hadn't thought of something like this. A shame, as I need to see him as part of a quest too!
    – Alex
    Dec 22, 2011 at 14:33

One possibility, something which I encountered, if you're waiting while the locked popup is open, the locked information will not disappear. Look away from the door and try again.

  • I've tried this. I've even run around the town, gone into and out of an inn (which is always open) and still no dice...
    – Alex
    Dec 21, 2011 at 21:59

For me, this always (almost) happen with Fletcher in Solitude.

If I wait until mid day and try to enter the store it's always closed. The only thing that works is to wait one more time (just one hour is enough).

Then the shop should be open.

I have no idea why this is the case though...


Some shop owners like to do late hours. If you 'wait' the shop should be open if you have waited for the right time, you don't have to continue to sit and 'manually wait' later.

Try waiting in 1 hour increments until you find the correct time for that shop to be open.


Look for the shopkeeper around town if you know what he/she looks like.

Sometimes quest related events or even dragon attacks inside the town pull them out of the shop. Also, ordag's answer suggestion here of looking away and back again definitely helped me a few times.

As an example for the quest related event, there is a quest in the Companions storyline where at one point, a crows of spectators form around the Jorrvaskr in Whiterun and one of the spectators was the blacksmith's husband. This crowd stays there indefinitely until you finish the quest and so the Blacksmiths house is locked till then. Other events in other towns may be keeping your shopkeeper occupied.

I don't know if any or all of the shopkeepers can be killed in dragon attacks on the town as I usually see them come out of the store after the dragon is killed. They usually stay there and comment on the dead dragon for some time.

If they are already dead, maybe you can resurrect them using the console? I don't play on the PC so I don't know the details.


In Whiterun, Warmaiden's is usually closed for me unless I talk to Adrianne Avenicci, I don't know if it's related to her saying "Check inside if you need anything else".

  • Warmaiden's is in Whiterun, not Solitude - fixed :)
    – Alex
    Dec 22, 2011 at 16:44
  • I usually just let myself in actually... The guy behind the counter, Ulberth Warbear, is normally there, even if the door is technically locked
    – Selonianth
    May 31, 2013 at 3:33

I had this problem as well, but I just left the city and re-entered it. Then the shop finally opened.


Necropost but with reason:

No-one mentioned the real issue.

If you stand in-front of the entrance or anywhere in the pathing of the NPC you disrupt their routine.

If you wait in-front of a locked door for 24 hours the NPC cannot open it on-time because you are in the way.

Had this issue in Whiterun with Belethor everytime. Now I wait on the well. Away from the door and not blocking paths.

Works Like A Charm.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .